Submit button is stuck on "Please wait"...

  • Profile Image
    NNWestcffd
    Asked on August 29, 2017 at 12:37 PM
    Also, not only can I still not review my selections before I submit, as they still won't show up, but now I can't even submit it as I click submit and it just says "please wait" but nothing else happens.
  • Profile Image
    BJoanna
    Answered on August 29, 2017 at 12:48 PM

    I was able to replicate mentioned issue when I tried to submit your form. The submit button was stuck on "Please Wait..".

    Considering that I am not able to replicate the issue on my cloned form, this issue is also most likely related to the Appointment slot widgets on your form. 

    Please update all of them and test the form again.

  • Profile Image
    BJoanna
    Answered on August 29, 2017 at 02:35 PM

    Your reply is not shown here on the forum, so I will quote your reply from the email that I received:

    "I did and it didn't work. You can go in and try it to see if it works.

    My colleague will update the widget as you request on your other thread. Hopefully, that will resolve both issues.