Already upgraded but it's still asking me to upgrade