My form loses/changes its selected theme and loses its custom CSS

  • Profile Image
    Mayasutra
    Asked on September 20, 2017 at 04:24 PM

    Hi,


    I'm having a problem with a form I'm working on (see url below) Almost every time I leave Jotform and by that I mean every time I stop editing a form or other activities on Jotform for a period of more than 2 hours (sometimes) less; the theme of my form changes. I checked the forum for possible solutions and I've done the following with no success. 

    I cleared form cache on Jotform 

    I cleared cache on my browsers


    The theme that I'm using is "simple grey". When I want to preview the form after having worked on it, it renders correctly. However, when I come back to the form later in a few hours to edit some more, it reverts to "Be my valentine" theme. In edit mode under themes, I've tried to toggle back and forth by setting "simple grey" as default theme in addition to current theme; but it still doesn't work. Almost always, after coming back to Jotform, when I click to edit form, under themes, it says "simple grey" is my "current theme" however the theme that's actually being displayed is "Be my valentine". (See screenshot) To fix this, I first click on any other theme to change away from "Be my valentine" theme and then I click "simple grey". Unfortunately, this happens every time and what's more is that each time, I lose all the custom CSS that I'd added to the form. 

    In addition to clearing cache of Jotform and browsers, I went to MAIN ACCOUNT Setting, and tried choosing "simple grey" as default Theme. But I couldn't find "simple grey" in available themes, so, I left the setting as it were. I have a premium account which was established before your pricing plas were restructured. I'm not sure if it has anything to do with this issue but I'm trying to be as detailed as I can so your team could remedy the situation more effectively. Please find a fix to this issue. Thanks. 

     

  • Profile Image
    jonathan
    Answered on September 20, 2017 at 05:29 PM

    I reviewed your form using its URL and I can actually see it using the 'simple grey' theme already.

    Can you please retry checking again using its URL https://form.jotformpro.com/72505979419974

    Let us know if still not working.

    ---

    If you set the dropdown list of the Themes to Free Themes you should be able to see the theme the form is using.

    example: