Stripe: Payments were not processed due to missing zip code on address?

  • Profile Image
    BrentwoodHalfMarathon
    Asked on October 03, 2017 at 12:20 PM

    I have mentioned this to you recently and you advised that postcode rejection was a Stripe problem. I have contacted Stripe and after several more people had a similar complaint, Stripe are suggesting the problem is the form is not sending the address/postcode information across. The Stripe log against these attempts does show no postcode or address details. So the rejection is not an incorrect postcode, it is the postcode has not been supplied. Our entrants are sure they have completed the address field, several attempts in most cases.

    The vast majority of entries are being processed OK. Unlike the previous system we used it does not like there is any record of 'failed' entries, so that we can check it out. The only record is in the Stripe log.

    What do you think?

  • Profile Image
    Kevin_G
    Answered on October 03, 2017 at 01:06 PM

    As I can understand, your users are getting an error when trying to submit the form, the error is related to the entered zip code. 

    Please note that the address should be passed from an "Address Field" to the payment integration, may be that during this process the information may be missing. 

    May you please provide us the form you're experiencing the issue on? 

    If possible, please provide us a screenshot of the error that's showing. It would be helpful if you may provide us a sample address that triggers the error, we will be glad to further test this on our end.