Form is not prompting for an encryption key

  • Profile Image
    pdratechnology1
    Asked on October 17, 2017 at 01:28 PM

    I sign in to view submissions but I'm not prompted for a key

  • Profile Image
    david
    Answered on October 17, 2017 at 02:20 PM

    It is possible there is a different key stored in the browser.  Try clearing your browsers cache/cookies or browsing in private/incognito mode.  Either of those should cause the submission page to ask to for a key.

  • Profile Image
    pdratechnology1
    Answered on October 17, 2017 at 05:51 PM

    I tried that, and it prompted for the key but when I put in the current key, it still did not decrypt the form.


    I've removed all entries, removed encryption, saved the form, logged out, logged back in, enabled encryption and had it generate a new key, downloaded that key, submitted a new entry on the form, cleared cache, loaded the submission, put the key in as prompted and still...gibberish. 

  • Profile Image
    John_Benson
    Answered on October 17, 2017 at 10:40 PM

    The newly generated key can only decrypt the new submissions. You will need the old private key to decrypt the old submissions.

    For more information about Form Encryption, please read this link: https://www.jotform.com/help/344-Encrypted-Forms-and-How-to-Use-Them

    I hope this information helps. 

  • Profile Image
    Patrick
    Answered on October 19, 2017 at 10:09 AM

    No that's not helpful because I said very clearly that I removed ALL old submissions, then created a new key, then submitted a new form entry.

    It's just NOT working!

  • Profile Image
    david
    Answered on October 19, 2017 at 11:17 AM

    Try removing the encryption and then cloning a new copy of the form:

    https://www.jotform.com/help/27-How-to-clone-an-existing-form-from-your-account

    Then apply encryption to the new copy, making sure not to select us existing key.  That should allow for fresh encryption to be applied using a new key.