Send Uploads as Attachment not working

  • Profile Image
    Konstantin_Vitkin
    Asked on October 25, 2017 at 06:29 AM

    Hello!

    I have a picture upload field in my form and also have email field.

    I noticed that if the email field is filled I don't get the picture attached to the notification email. If the email field remains empty I receive an attachment.

    I also don't get the picture at all, don't see it in the submission section!

    How can I fix it?

  • Profile Image
    lumiardian
    Answered on October 25, 2017 at 08:48 AM

    I tested out the form and it seems like you have some js error and that might the be reason why you aren't getting the email, or vice versa. I suggest to check the errors first.1508935688message.png

  • Profile Image
    Kiran
    Answered on October 25, 2017 at 10:38 AM

    @Konstantin_Vitkin,

    I have checked the upload field on a test form and it is working normally at my end. As I check your JotForm, I notice that the upload field is not a required field and there is a chance that the user hasn't uploaded the files to the submission. Please mark the upload field as a required field and see if you are receiving the files to the submissions and attachments in the email notification. You may right-click on the field and select Require option to make the field as a mandatory field.

    Please get back to us if you need any further assistance. We will be happy to help. 


  • Profile Image
    Konstantin_Vitkin
    Answered on October 25, 2017 at 12:26 PM

    Kiran, thank you for trying to help, but I think you didn't understand my problem. I will explain it.

     

    1. There are no users. I'm testing a form alone. So, I upload a picture and don't see it in submission and in the notification email.

    2. There is some relations between the email field and upload field.

    As I mentioned:

    If the email field is filled I don't get the picture that I have upload. If the email field remains empty I receive a picture.

    Furthermore, if I mark an upload field as "required" and upload a picture and write an email in his field, I get an error "Incomplete values" for the upload field.

    3. In other words, if the email field is filled somehow the form thinks that there is no file in the upload field.

  • Profile Image
    Kiran
    Answered on October 25, 2017 at 01:51 PM

    I have just sent a test submission to your form by filling the email address field. As I check the email history log for the email sent, I am able to see that the file upload field is displayed normally in the email. Could you check if the email received has the attachment of the file? 

    150895367625102017_231727.png

    Also, as I tried to submit the form with the email address filled, I was able to submit the form without any errors at my end. 

    Please try opening the form in a private/incognito window or a separate browser to see how it works. I have also cleared the form caches for your account if that helps.

    Please get back to us if the issue still persists. We will be happy to assist you further.