New Layout: Unable to edit form submissions

  • Profile Image
    isingleparent
    Asked on October 26, 2017 at 12:25 PM

    Hi, please help on urgent basis. I am unable to edit the submitted forms from my clients. The screen stays stuck as in the screenshot. I have cleared cache etc but nothing is helping. I faced this issue once before as well but then your developer had resolved it at your end and I was then able to edit.

    Please help. Thanks

  • Profile Image
    Chriistian
    Answered on October 26, 2017 at 01:34 PM

    This seems to be a similar issue as your thread here: https://www.jotform.com/answers/1283254. My colleague has responded to you there. Please check the thread.

  • Profile Image
    isingleparent
    Answered on October 26, 2017 at 02:43 PM
    Hi,
    Thank you for your response again.
    I tried with a different browser, with a different internet connection,
    cleared cache, tried different devices, using my phone as well but nothing
    seems to be helping. I urgently need to edit the field in the form to
    approve certain submissions.
    I recorded my screen to show you the problem I am facing across devices.
    You may check the screengrab here: https://drive.google.com/file/d/
    0B41W3oc4TElBeFRRanFlc0VDVms/view
    I am not sure why you are not able to clone this issue. I faced this
    earlier as well few months back, but at that time also, the problem was
    resolved from your back-end only.
    Look forward to your support in resolving this.
    Regards,
    *Richa Sharma*
    ...
  • Profile Image
    Mike
    Answered on October 26, 2017 at 04:16 PM

    We have checked the submissions page from different locations including India, but we were not able to reproduce the issue.

    Could you please try the editing while the browser console is open to see if there are any errors?

    1) This is how the console can be checked:

    How to get a console report from most common browsers

    2) Provide us with the screenshot of the errors (if any):

    How to Post Screenshots to Our Support Forum

    Thank you.

  • Profile Image
    isingleparent
    Answered on October 28, 2017 at 12:43 PM
    Hi,
    I shared a link of the recording of my screen with you. Sharing it again
    here..... https://drive.google.com/file/d/0B41W3oc4TElBeFRRanFlc0VDVms/view
    ....it's
    a short video, please have a look so as to understand the issue I am
    facing. I am feeling very helpless as I have an event tomm for which people
    filled in the form to register and now I am unable to "Approve" and send
    them confirmation.
    I tried the console report also, it's not showing any error I suppose.
    Attaching the screenshot.
    Please help. I have tried all your suggestions already!
    ...
  • Profile Image
    isingleparent
    Answered on October 28, 2017 at 12:51 PM

    Ok I tried to open the form submissions via Safari this time....attaching the screenshot of the Console here...... In safari, I am not able to go beyond the "Start" button also.1509209457Screen Shot 2017-10-28 at 10.1

  • Profile Image
    isingleparent
    Answered on October 28, 2017 at 01:43 PM
    Adding to my prior email, in the screenshot if you can see, there's a red
    random blank button showing right above the green "create your own
    jotform".....seems to be a technical snag at your end. What is that red
    button??
    ...
  • Profile Image
    BDAVID
    Answered on October 28, 2017 at 03:48 PM

    We have forwarded this to our developers, you will be notified via this thread when it gets fixed.

  • Profile Image
    isingleparent
    Answered on October 28, 2017 at 11:43 PM
    I was telling all along that the issue is from your back end. My event is
    today and this is so embarrassing that we were not able to send out formal
    approvals and registration IDs to the people who registered for the event.
    It took jotform 3 full days to listen and still no resolution. Very
    disappointed.
    ...
  • Profile Image
    isingleparent
    Answered on October 30, 2017 at 01:43 AM
    Is the problem being worked up on? There is no update whatsoever and I am
    still not able to edit forms. Please do let me know..... thanks
    ...
  • Profile Image
    Chriistian
    Answered on October 30, 2017 at 03:38 AM

    Apologies for the inconvenience this has caused you.

    There is no update yet regarding this issue. I have sent a message to our developer who is assigned to this. Rest assured you will be informed in this thread as soon as we get any updates.

    Thank you for your patience.


  • Profile Image
    isingleparent
    Answered on October 30, 2017 at 11:43 AM
    Hi, would appreciate a timeline being provided that in how much time the
    issue will be resolved. it's been a week since I am unable to edit my form
    submissions and following up for a solution.
    The only reason why I am even following up on this is because of all the
    re-work i'll have to do if I move to a Mailchimp or other service provider.
    But if there is no resolution or a timeline, I'd rather just move out of
    Jotform without wasting my time any longer.
    ...
  • Profile Image
    Chriistian
    Answered on October 30, 2017 at 11:56 AM

    I have sent a message to the developer handling this issue but it seems the developer is not yet online. Will inform you on this thread once I received a response from the developer. 

    If you need to edit the submission of your form, can you try to use the edit submission link for the meantime while this is being investigated? The format of the edit submission link is like this: https://www.jotform.com/edit/{submissionID}

    Just replace the {submissionID} to the id of the submission you want to edit. For example:https://www.jotform.com/edit/3848414837217011325.

  • Profile Image
    irem
    Answered on November 28, 2017 at 08:06 AM

    Hello,

    We are sorry for the inconvenience caused.

    The problem should be fixed now. Please check it and let me know if you need anything.

    Thank you!

  • Profile Image
    isingleparent
    Answered on December 05, 2017 at 12:43 AM
    Hi,
    The issue still isn't resolved. So upon lot of attempts at my end, I
    realized if I first "unhide" the hidden fields in any of my form and then
    try to edit the submissions from the back end , the form works ok. However,
    it adds unnecessary steps to again go back to the form and enable the
    "hide" option on the fields which I initially unhid just so I could edit
    the submissions.
    So the problem is with the hidden fields of the form which do no display
    while I m trying to edit any form submission from the back end.
    This still needs to be resolved. It may be a temporary solution but very
    annoying in the long run.
    Please look into this. Thanks.
    ...
  • Profile Image
    Chriistian
    Answered on December 05, 2017 at 02:28 AM

    You can uncheck the autohide empty fields from the settings on the submission page to unhide the fields without unhiding it on the form. Then try editing the submissions.

    15124587782017-12-05_1525.png

    However, if this is not the case, please do get back to us.

  • Profile Image
    isingleparent
    Answered on December 05, 2017 at 02:43 AM
    Hi,
    Thanks for your response. I did as per your instructions and unchecked the
    "Auto Hide Empty Fields" but the issue still remains.
    In the back end, when I try to edit a form submission, I press on "start"
    and the welcome street exits. However nothing happens after that. Attaching
    screenshot.
    ...
  • Profile Image
    Chriistian
    Answered on December 05, 2017 at 03:52 AM

    Did you attach a screenshot image of the issue in your previous reply? If yes, it seems it did not reach the Support Forum. Please try again by following the instructions this guide: How to Post Screenshots to Our Support Forum

  • Profile Image
    isingleparent
    Answered on December 12, 2017 at 11:55 PM

    Hi,

    Yes I attached a screenshot to my last message to you. The problem/issue with editing Jotform submissions from the backend hasn't changed one bit from Day 1 of my complaint on 26th October 2017. The screenshot which I attached on 26th Oct 2017, and the screenshot I tried to attach in my last message to you or the screenshot I will attach in this message, all display the exact same issue even though taken on different dates, that I am not able to see the form fields (hidden or not hidden) to be able to edit them. 

    I hope you can understand the frustration I am feeling as it's been over a month. Problem is I need to be able to edit the forms already submitted if I even decide toshift base from Jotform to some other service provider. I was really happy with your service but this has been a damper. Anyway, without taking more time, please see the attached screenshot. 

    I even attached a screengrab "video" to explain the issue in my message dated 28th October, not sure if anyone watched it to understand what I am trying to explain.

    1513140741Screen Shot 2017-12-13 at 10.2

    1513140774Screen Shot 2017-12-13 at 10.2

    1513140855Screen Shot 2017-12-13 at 10.2

    1513140884Screen Shot 2017-12-13 at 10.2

  • Profile Image
    isingleparent
    Answered on December 13, 2017 at 12:01 AM

    In addition to my above message. Please note, if I even try to edit the form submissions using this method:

    Just replace the {submissionID} to the id of the submission you want to edit. For example: https://www.jotform.com/edit/3885561988515366479

    I am not able to edit as the form field is sticking in the extreme right edge of the browser/page and I am not able to access the "Next" or "Submit" button. Attaching screenshot:

    1513141262Screen Shot 2017-12-13 at 10.2

  • Profile Image
    ashwin_d
    Answered on December 13, 2017 at 04:46 AM

    I'm sorry for the trouble caused to you.

    I did try to use your form's edit link and I am able to replicate the issue you are having. Form me, none of the form fields were displayed. Please check the screenshot below:

    1513158080editLink.gif


    I am updating the ticket and sending a note to assigned developer as well. We will get back to you as soon as we have any update on this.

  • Profile Image
    ashwin_d
    Answered on December 14, 2017 at 04:09 AM

    It seems the issue is now resolved. I was able to access your form submission edit link successfully. Please check the screenshot below:

    1513242376editLink.gif


    If the issue persists, I would suggest you to please clear your browser cache and that should solve your problem. The following guide should help you how to clear your browser cache:   http://www.wikihow.com/Clear-Your-Browser's-Cache 

    Hope this helps.

    Do get back to us if the issue persists.

  • Profile Image
    isingleparent
    Answered on December 14, 2017 at 08:43 AM
    Hi Ashwin,
    Thanks for your response. Unfortunately, the issue isn't resolved, let me
    explain:
    1. At the time you were able to replicate the issue, my form was using a
    widget called "Unique ID" to generate a unique member ID at form field #2.
    The widget was functioning fine, however, when I tried to edit the form
    submission from the back end I was having the issue which you were able to
    replicate the last time.

    2.
    To temporarily get rid of the issue, today, I removed the widget from my
    form now and added a new field to provide unique Member ID's manually.
    Therefore, you are not seeing any issue right now. But for a permanant
    solution, I need the Unique ID widget to work on my form as filling the
    Member IDs manually every time is a cumbersome process.

    3.
    Please also note, that Field #1 i.e. Member Status and Field #2 i.e.
    Member ID on the form are both "hidden" fields. As an admin, I used to be
    able to see/access these fields from the back end whenever I tried to edit
    the form submission without having to follow any additional steps. However,
    post 27th October, I have no clue what has changed but now every time I
    have to edit a form submission, I require to first go to "Edit the form"
    and unhide Field #1 and Field #2 and then go to "Edit form submissions" to
    be able to edit the form else the issue as you replicated, arises and the
    fields don't display.

    I will share a screengrab video if you are not able to understand or
    replicate what I am saying. Please help. Thanks.
    ...
  • Profile Image
    Rose
    Answered on December 14, 2017 at 10:03 AM

    I'm not sure if you check edit submission functionality with unique ID widget after my colleague replied. I made some tested on your account and here is my outcomes:

    1. I cloned this form: http://www.jotform.me/form/72571928792470

    2. I added Unique ID widget to the cloned form: http://www.jotform.me/form/73473661823461

    3. I made a test submission to the cloned form. 

    4. Then, I go to submission page of the cloned form and click to edit. 

    Result is the same as before. I was not able to replicate the issue on my side. All the hidden fields and unique ID widget were seen. Here is the screencast of my tests:

    1513263683demo.gif

    On the other hand, I have encounter another problem during my test. If there is a unique ID widget on the form and when you try to edit this form submission through edit submission page, it is not possible to submit the form. Here is the screencast of how I replicated this problem:

    1513263710aaa.gif

    I'm going to open a ticket for the second problem but could you please confirm that the issue you are having is the same as the one I replicated which is regarding the submit function on edit submission while the unique ID widget is being on the form?

    Note: The cloned form also in your account and you can delete if you want. I remain it there for your evaluation. 

  • Profile Image
    Rose
    Answered on December 15, 2017 at 03:58 AM

    We are terribly sorry for the inconvenience caused to you. 

    We investigated your issue further and come to three different conclusions. There are three different bugs regarding edit submission feature. 

    1. The first problem is related to see hidden fields on submission edit mode. This problem was fixed by one of our developers recently but as I tested today, it is still not possible to display hidden fields for the regular users even though admin privilege accounts do not have this issue. This is why, every time we test your form, we did not see the problem. 

    2. While I tested your form yesterday, I realised a problem regarding unique ID widget and review before submit feature. Please note that this is another problem different than the first one. If Unique ID widget is used while the review before submit feature is enabled, it is not possible to submit form on edit submission through edit submission page.However, This happens only when the user tries to edit submission through submission page. This works as expected on edit submission link on the notification email. 

    3. The last problem is also related Unique ID widget. When this widget is used on the form, it is not possible to display all fields on submission edit mode. Again due to admin privilege, we were not able to detect the issue but we know that regular users have this problem. 

    All in all, as three different problems reported via this thread and the ticket becomes confusing and becomes very long to track root cause of the problems, I split these two problems to different threads and opened tickets for both of them in the priority of Very Important. 

    Ticket regarding first problem: https://www.jotform.com/answers/1324288-New-Form-Layout-It-is-not-possible-see-hidden-fields-on-submission-edit-mode-

    Ticket regarding second problem: https://www.jotform.com/answers/1324286-New-Form-Layout-Edit-submission-functions-is-not-possible-if-the-Unique-ID-widget-and-review-before-submit-feature-are-used-together-

    Ticket regarding the third problem: https://www.jotform.com/answers/1324306-New-Form-Layout-Fields-are-not-seen-on-submission-edit-mode-if-Unique-ID-widget-is-used-on-the-form-

     

    Please follow up these three tickets for our returns. Once these two problems are fixed, you will be notified via the related threads. We again thank you in advance for your understanding and cooperation.