Full contents of submitted form not coming through

  • Profile Image
    singingman
    Asked on October 27, 2017 at 08:13 AM

    The first field of my form is a compulsory name field. Usually when I get email confirmation I get the name at the end of the subject line and in the From field.

    Occasionally however I get submissions with no name either in the subject line or body of the email. The Reply-to field has their correct email address in. When I look at the submission in the online inbox, the name is also missing there.


  • Profile Image
    Rose
    Answered on October 27, 2017 at 09:56 AM

    As you keep your data at our EU server, someone from our support team in EU zone must handle your problem.

    1509112552Screen Shot 2017-10-27 at 17.0

    I'm escalating this thread to one my colleague in EU zone. You will be replied within at latest 24 hours. 

  • Profile Image
    BJoanna
    Answered on October 27, 2017 at 10:34 AM

    I tested your form and I was able to replicate the issue. This will happen only when 'Bank Transfer' option is selected and it is happening because of the conditions you set inside of the form and the form settings. 

    You set a condition to hide First Name field if the 'Bank transfer' option is selected. 

    1509114224hide.JPG

    Also, inside of the Form Settings, you set the Clear Hidden Field Values to Clear on submit, which will clear the value from the hidden full name field. 

    1509114466clear.JPG

    To resolve this issue you can modify your condition and remove full name field from conditions or set the Clear Hidden Field Values to Don't Clear

    Hope this will help. Let us know if you need further assistance. 

  • Profile Image
    singingman
    Answered on October 27, 2017 at 11:22 AM

    Many thanks! Hiding the name field was just a stupid error on my part. Don't know how I didn't notice it!!!

    Thanks for pointing out the Clear on Submit option. I wasn't aware of that. All sorted now.