Why is my form stuck on please wait when trying to submit it?

  • Profile Image
    mariamst
    Asked on November 16, 2017 at 02:12 PM

    I just published an online form using the Appointment Slots widget. However, participants informed me that after pressing the Submit button, the message 'please wait' appears and the page doesn't load. Can someone help as this is rather urgent?

    Thank you in advance.

    Maria

  • Profile Image
    Richie_P
    Answered on November 16, 2017 at 03:03 PM

    Hi,

    I have cloned your form and it worked perfectly in my browser.

    Make sure to allow cookies and enable them for the widgets to get information in the browser.

    Regards.


  • Profile Image
    mariamst
    Answered on November 16, 2017 at 06:06 PM

    Thank you for your answer.

    Can you please be more specific? How can I enable cookies for widgets? 

    I tried to fill in the form on other devices but it doesn't work there either.

    Thank you!

    M.

  • Profile Image
    Kevin_G
    Answered on November 16, 2017 at 08:42 PM

    I have been testing your form and was able to replicate the issue you mentioned, but it seems like the problem was related to the widgets. 

    I already refreshed their API info by updating the widgets from the wizard, this worked on my end and I was able to submit the form without any problem. 

    Please test your form again, if possible use incognito mode in order to avoid any cache conflict, let us know how it goes. 

  • Profile Image
    mariamst
    Answered on November 17, 2017 at 03:58 AM

    Hi,

    the problem was resolved and I have already started receiving submissions.

    Thank you very much for your help!

    Maria