Why do my forms keep jumping around in iframe?

  • Profile Image
    The_Mighty_Optiq
    Asked on September 15, 2012 at 09:44 PM

    I decided to start a new post on this with a more organized approach because the other one kinda carried into this when it started as something else.... but here we go....

     

    I'm nesting forms inside of forms with iframes to help give a little more user interaction with my sales forms... I have the main form which is this

    http://jotform.us/form/22588042233147

     

    The only link I have working in there is Shirts > Men... then this form opens in the iframe under it..

     

    http://jotform.us/form/22498572408159

     

    This loads with a blank page as its' suppose to and all the links up top work but when you click on one... it loads to that anchor tag then jumps around and stops somewhere else... then you have to click the shirt you want again for it to go to it....  

     

    Then in that area I have ANOTHER form nested in an iframe for the actual options.... which is

     

    http://jotform.us/form/22101516710134

     

    This one skips around too.  I have them all set to load up to the Spec section for each shirt by default but they skip back and forth.. and with this one when I go in to edit it it'll scroll down n get stuck and I'll  have to zoom back X2 or 3 to be able to scroll up....  thanks in advance.... 

  • Profile Image
    liyam
    Answered on September 15, 2012 at 10:35 PM

    After doing some tests, I found out that the cause of this problem is the hash (#) in the src value of the iframe.  When I tried removing the #default it stopped the focusing on that part of the page when it was loading.  Unfortunately, this is a browser behavioral issue and the only work around for these are using javascripts which is not allowed to be added in JotForm based forms.

  • Profile Image
    The_Mighty_Optiq
    Answered on September 16, 2012 at 12:19 AM

    hmmmm...... looks like I'll just have to have a window saying "please choose an option below" or something so it automatically loads to that... because the links go to the right place... it just loads all crazy.... thanks!!! :)

  • Profile Image
    The_Mighty_Optiq
    Answered on September 16, 2012 at 12:48 AM

    ok I took the # off the links in the iframe sources... but it still scrolls and jumps around... 

  • Profile Image
    liyam
    Answered on September 16, 2012 at 03:07 AM

    It seems you were not able to save your form properly.  I checked the source code of your form and it still appears this "#default" in the src value of your iframe.

  • Profile Image
    The_Mighty_Optiq
    Answered on September 16, 2012 at 02:51 PM

    hmmm... don't know how that happened.... but I just changed it and it all loads up without jumping around...  but one thing I'm still having a problem with is with http://jotform.us/form/22101516710134 when I go to edit it it still jumps down half the page and stays stuck unless I zoom out... then it'll allow me to scroll a couple times before it gets stuck again...  

  • Profile Image
    The_Mighty_Optiq
    Answered on September 16, 2012 at 03:07 PM

    ok it stopped now....

  • Profile Image
    jonathan
    Answered on September 16, 2012 at 03:49 PM

    Thank you for updating us. Do inform us if the issue persists, and we will be more than glad to help.