Why cash payment option is still directing to PayPal?

  • Profile Image
    wsctn8
    Asked on November 27, 2017 at 08:16 AM

    Hi!

    My form @ https://www.jotform.com/build/73102619044145 has two payment options. I posted a previous question and was given the instruction to either set conditions (show paypal, etc) OR set-up different conditional thank you pages. I have tried both unsuccesfully. I'm in a crunch and need this operational ASAP this morning.


    It appears that the PayPal section of my form (which gets its price from a Calculation) is ALWAYS present. Even when I set a condition to show it for Card Payment and set a separate condition to show other text for Cash Payment. No matter what, the submit button always takes people to the PayPal link.


    It doesn't matter to me whether it is conditional show/hide or conditional thank you pages. (I don't know how to set the conditional thank you page to go to submission instead, if you think that is easiest.)

    I JUST REALLY NEED cash to go straight to submit, PLEASE HELP!

  • Profile Image
    Nik_C
    Answered on November 27, 2017 at 11:05 AM

    I checked your form a conditional logic seems fine. So I tested and choose Cash, so the form submitted directly, without redirecting to PayPal, which is, from what I understood, the way you want it.

    1511798686Screen Shot 2017-11-27 at 5.08

    If you're still experiencing any issues please get back to us.

    Thank you!

  • Profile Image
    wsctn8
    Answered on November 27, 2017 at 11:16 AM

    I just went straight to my form and tried it as a customer would. It still directs me to PayPal when I choose cash. Not sure why it worked on your end and not mine?? Lol


    Heres the site I'm using:

    https://form.jotform.com/wsctn8/on-site-nutrition-ordering


    Please help!


    Thank you for your quick response. 

  • Profile Image
    Nik_C
    Answered on November 27, 2017 at 11:41 AM

    Please check the direct link of you form:  https://form.jotform.com/73102619044145

    Since that's the one I was testing. Also, the custom link that you provided https://form.jotform.com/wsctn8/on-site-nutrition-ordering is not the custom link of that form anymore: 

    1511800729Screen Shot 2017-11-27 at 5.42

    So probably that's why the form wasn't working properly.

    Please check the direct link to the form, and if needed create a custom one again. 

    Let us know how it worked.

    Thank you!