New Layout: Receiving "Oops! Submission ID is wrong" when editing a submission.

  • Profile Image
    justismartinez
    Asked on January 25, 2018 at 03:43 PM

    We have a form that requires editing by a manager after initial submission. In the manager notification email, I've inserted the "Edit link" option from the Form Fields drop-down. It hasn't been styled or amended in any way.

    When the manager clicks the link from their email, the form loads correctly with all form data as well as the conditional fields they should see on Edit.

    However, when the manager clicks submit, they receive the "Oops! Submission ID is wrong."

    Any idea why or what I can change?

  • Profile Image
    Kevin_G
    Answered on January 25, 2018 at 06:31 PM

    Apologies for the inconveniences this may have caused to you. 

    I have been testing this and I can replicate the problem you mentioned. I will forward it to our second level so our developers can have a look on it, we will keep you updated via this thread. 

  • Profile Image
    justismartinez
    Answered on January 26, 2018 at 11:12 AM

    Thanks, Kevin. Any idea when we might hear something back from that second team?

  • Profile Image
    Kevin_G
    Answered on January 26, 2018 at 12:34 PM

    I have been informed by our second level that they cannot replicate the issue, I have tested my form and it seems to be working now; however, on your form I can see the issue still happens so I will let our developers know about it.

    We will keep you updated on this thread. 


  • Profile Image
    irem
    Answered on February 06, 2018 at 03:24 AM

    Hello,

    We are sorry for the inconvenience caused.

    Since we didn't replicate the issue you're having and your mentioned submission was deleted; I'm canceling this ticket. Please feel free to open a new thread if you face this issue in the future.

    Thank you for contacting us.