I am still struggling with this one.

  • Profile Image
    bhpinfo
    Asked on October 09, 2012 at 11:59 AM

    I am still struggling with this one. Other methods, using embed code don't work for me, so I gave this method a go.

    It saved the form fine for a change, but it lost all of the nice formatting and converted it to plain bulleted list etc.

    How do I fix that?



    This is a re-post of a comment on Finding The HTTP Page From Which A Submission Came

  • Profile Image
    Rodjit
    Answered on October 09, 2012 at 12:59 PM

    Hi,

    Can you please provide us your form URL or the website where your form is embeded so we can check it and give you further solutions.

    Thanks

  • Profile Image
    bhpinfo
    Answered on October 10, 2012 at 03:43 AM

    Hi Rodjit,

    This is the url: http://www.lawdonut.co.uk/law/ownership-and-management/shareholder-and-boardroom-disputes.

    The page is live so I don't want it in that state there for much longer.

    Thanks,

    Kasia

  • Profile Image
    Rodjit
    Answered on October 10, 2012 at 03:53 AM

    Hi Kasia,

    It works fine using Chrome, but not in FF and IE and we are sorry for this. Please try to embed your form using iframe method and let us know if it doesn't help.

    Thanks

  • Profile Image
    bhpinfo
    Answered on October 10, 2012 at 04:11 AM

    Hi Rodjit,

    I can't use iframe or embed method as mentioned in my initial question. The CMS doesn't allow it and changes the code, see here: http://www.lawdonut.co.uk/law/ownership-and-management/shareholder-and-boardroom-disputes.

    Kasia

  • Profile Image
    Rodjit
    Answered on October 10, 2012 at 04:30 AM

    Hi Kasia,

    Your website CMS is Drupal and I do understand that its a bit tricky to embed iframe into a Drupal page. But have you check this guide on adding forms to Drupal?

    Does embedding the form full source codes don't work? Please try.

    Thanks

     

  • Profile Image
    bhpinfo
    Answered on October 10, 2012 at 04:46 AM

    Hi Rodjit,

    I am fine embedding form into Drupal using the embed code, but as soon as I add the code for url tracking it disappears.

    I used full source code as well when I raised my initial question. Drupal doesn't seem to like parts of javascript used in that and changes the code to ignore them.

    Kasia

  • Profile Image
    idarktech
    Answered on October 10, 2012 at 05:08 AM

    @Kasia

    The problem might be related to drupal which strips out iframe embed codes. Please check thread as it may help you fixed the iframe problem: http://drupal.org/node/69236

    Let us know if this doesn't help so we can further assist you. Thanks!

  • Profile Image
    bhpinfo
    Answered on October 10, 2012 at 05:40 AM

    Hi idarktech,

    I had no luck yet. Drupal is already configured to include iframes module in wisiwyg, but there is no option for that in input formats.

    Whenever I add this code to the page:

    <script type="text/javascript"> document.write("<iframe allowtransparency=\"true\" src=\"http://www.jotform.com/form/21994434111955?referrer=" + window.location.href + "\" frameborder=\"0\" style="width:100%; height:529px; border:none;" scrolling=\"no\"></" + "iframe>");</script>

    it turns into this after saving the page:

    <script type="text/javascript">// <![CDATA[

    document.write("<iframe allowtransparency=\"true\" src="\" mce_src="\""http://www.jotform.com/form/21994434111955?referrer=" + window.location.href + "\" frameborder=\"0\" style="width:100%; height:529px; border:none;" scrolling=\"no\"></" + "iframe>");

    // ]]></script>

  • Profile Image
    idarktech
    Answered on October 10, 2012 at 06:02 AM

    Hello,

    I just notice a slight problem with your embed code, there were no backslahses "\" on the style part, please use this instead: http://pastie.org/pastes/5028811/text

    Update us if this doesn't help. Thanks!

  • Profile Image
    bhpinfo
    Answered on October 10, 2012 at 06:07 AM

    I've pasted the code you've given and after saving the form is still not showing and the code was changed to:

    <script type="text/javascript">// <![CDATA[
    document.write("<iframe allowtransparency=\"true\" src="\" mce_src="\""http://www.jotform.com/form/21994434111955?referrer=" + window.location.href + "\" frameborder=\"0\" style="\" mce_style="\""width:100%; height:529px; border:none;\" scrolling=\"no\"></" + "iframe>");
    // ]]></script>

  • Profile Image
    idarktech
    Answered on October 10, 2012 at 06:37 AM

    @bhpinfo,

    I'm not quite familiar with drupal but I'm sure the issue was related to their embed filtration. Like you've observed the embed code was changed to js comment so it can't execute properly. Have you tried using widgets like this? http://drupal.org/project/embedfilter this may help you embed source codes to your drupal pages or posts.

    This article may also help: http://www.drupalgardens.com/documentation/adding-custom-javascript

    May I also suggest to contact drupal support regarding this. I'm sure they can provide you more details about this issue.

    Thank you for your patience!

  • Profile Image
    bhpinfo
    Answered on October 10, 2012 at 07:57 AM

    Hi,

    I have eventually managed to make it work. If anyone else ever struggles with this I have done it by creating a new text format and then adding embed version of the code (iframe didn't want to work for some reason).

    Thanks for all your help.

    Kasia

  • Profile Image
    Rodjit
    Answered on October 10, 2012 at 08:22 AM

    Hi Kasia,

    We are glad that you have sorted it out and we thank you for such information/solution that you've shared to us. This is very helpful to others that might experience the same issue as yours.

    Thanks again and let us know for any questions. We are here to help