Condition to hide pages does not seems to work.

  • Profile Image
    SAFEINTHESEAT
    Asked on February 06, 2018 at 10:09 AM

    I have published the form and then when it to test it as a user.  when i finish a page it does not give me any option to advance to the next page.  there is nothing to click or to do to move on. help!

  • Profile Image
    aubreybourke
    Answered on February 06, 2018 at 11:26 AM

    That's because in your 4 conditions you are hiding the next button

    1517934346The Easiest Online Form Builde

  • Profile Image
    SAFEINTHESEAT
    Answered on February 06, 2018 at 12:43 PM
    OK thank you! I fixed it to allow me to advance, but now when I do so it just shows a blank page. I tried it with it showing page break and not showing page break at the end of the hidden items. Help!
    Michelle Pratt
    ...
  • Profile Image
    david
    Answered on February 06, 2018 at 02:01 PM

    For what you are looking to do, I would recommend using hide page conditions instead of trying to hide each field individually. 

    1517943603Capture.PNG

    The hidden pages will be skipped.

  • Profile Image
    SAFEINTHESEAT
    Answered on February 06, 2018 at 08:43 PM
    Ok, I did that and it is still not working. Now when I enter “1” car seat is still shows me pages 4, 5, and 6 only hiding page 3.
    Michelle Pratt
    ...
  • Profile Image
    ashwin_d
    Answered on February 07, 2018 at 01:51 AM

    I have cloned your form and working on the condition. I will get back to you on this soon.

  • Profile Image
    ashwin_d
    Answered on February 07, 2018 at 01:59 AM

    I cloned your form and changed the condition to hide pages based on the selection of dropdown field. Please check the screenshot below for the conditions I have added:

    1517986641hideCond.png

    Please take a look at the following cloned form and see if this works as expected:   https://www.jotform.com/80370615894967 

    Feel free to clone this form for a closer look at the condition. The following guide should help you in form cloning:  https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL 

    Hope this helps.

    Do get back to us if you need any other changes.

  • Profile Image
    SAFEINTHESEAT
    Answered on February 07, 2018 at 09:43 AM
    Thank you. However, I just tested it entering “1” and it still isn’t working. This is so frustrating!!
    Michelle Pratt
    ...
  • Profile Image
    ashwin_d
    Answered on February 07, 2018 at 11:08 AM

    Did you test my form where I edited the conditions? Please check the following form again and see if it works as expected:   https://www.jotform.com/80370615894967 

    I did test my form and it seems to work just fine. I did test "Number of Car Seats" form 1-5 and all works just fine. Please check the screenshot below:

    1518018874testForm.gif

    I would suggest you to please test this form again and get back to us if there is any problem.

    We will wait for your response.

  • Profile Image
    SAFEINTHESEAT
    Answered on February 08, 2018 at 06:43 PM
    Well now the address field isn’t working and its required so it won’t even let me move past the first page to test it.
    Michelle Pratt

    ...
  • Profile Image
    Kevin_G
    Answered on February 08, 2018 at 09:31 PM

    Since your last question is not related to the original matter on this thread, I have moved it to another one, we will help you as soon as possible here: https://www.jotform.com/answers/1378695 

    Thanks. 

  • Profile Image
    SAFEINTHESEAT
    Answered on February 08, 2018 at 10:43 PM


    It is related because somehow when you went in the form you messed that section up and now I can’t even check the feature i am trying to resolve!





    ...
  • Profile Image
    ashwin_d
    Answered on February 09, 2018 at 03:12 AM

    when you went in the form you messed that section up

    Please note that we did not make any changes in your form. We cloned your form and then edited the conditions. I also checked your form and the address field seems to work just fine. I was able to go to second page. Please check the screenshot below:

    1518163843cond.gif

    I would suggest you to please test your form again and get back to us if the issue persists.

    We will wait for your response.

  • Profile Image
    SAFEINTHESEAT
    Answered on February 09, 2018 at 11:43 AM
    I give up!! On page 1 when I put in 1 car seat as the number of car seats, it takes me to the car seat page 1. Then when I click next it takes me to Car Seat 3 page.
    Michelle Pratt
    ...
  • Profile Image
    aubreybourke
    Answered on February 09, 2018 at 12:26 PM

    I see there are two separate problems:

    1) The autocompleted address widget is failing to respond to input. I believe this is because there might be a limit as to how many times in can be used in any given time. As we are all frequently testing here it seems to have blocked from overuse.

    2) Your hide page conditions are failing to work.

    1518196677The Easiest Online Form Builde

    I see that my colleague suggested a different approach. Which works somewhat better. But really your conditions should work too. 

    So I have escalated this issue to Level 2 support. The developers will look into why the hide conditions are failing to work. And provide a response when they are ready.

  • Profile Image
    aubreybourke
    Answered on February 09, 2018 at 01:34 PM

    Can you please try testing this form:

    https://form.jotform.com/80394705728969


    If it works for you then please clone it:

    How-to-Clone-an-Existing-Form-from-a-URL


    If that's too confusing, you may consider using collapse fields instead:

    Show-or-Hide-Multiple-Fields-at-Once-Using-the-Section-Collapse-Field