What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Lightbox position.

    Asked by tupperwareconsultant on February 11, 2011 at 03:02 PM

    Hi,

    I have placed several forms to open up as the lightbox feature so that the form opens up in the centre of the Screen. However, on IE8, I see that the lightbox opens partially (in the top left corner) and the form is not wholly visible. The site is here. However, the lightbox opens up perfectly on Chrome,Firefox,Opera,Safari.

    Is this a bug or a known issue? I have browsed the forum but did not get an answer.

    Please help as this is the lifeline of the site!!!

    Thanks in advance. Seeta

  • Profile Image
    JotForm Founder

    Answered by aytekin on February 15, 2011 at 01:24 AM

    I added this to our bug list. We will look into it and get back to you.

  • Profile Image
    JotForm Support

    Answered by seyhuns on February 15, 2011 at 10:51 AM

    Hello,

    We have fixed this problem in our new Lightbox option. You can use the new one under "Embed Wizard" in "Setup & Share" tab.

  • Profile Image

    Answered by treetopsbenllech on February 15, 2011 at 05:38 PM

    Hi there,

    I have the same problem. In Chrome the lightbox is perfectly centred but in IE the lightbox is of to the top left hand corner, i have used the Embed Wizard and no luck can you help?

     

    Thanks

  • Profile Image

    Answered by tupperwareconsultant on February 15, 2011 at 10:27 PM

    Hi seyhuns,

    I have tried to use the 'Embed Wizard' but to no luck. Can you please help. When I use the Embed code, it breaks up the links to all the other forms on the page (which I think is a different issue). Is there any other workaround?

    Thanks in advance.

  • Profile Image
    JotForm Support

    Answered by seyhuns on February 16, 2011 at 04:31 AM

    @tupperwareconsultant:

    I can see in your page that you are not using the Lightbox code from "Embed Wizard".

    The new "Embed Wizard" has a code like this:

    <script src="//www.jotform.com/min/g=feedback" type="text/javascript">

    new JotformFeedback({

    formId:'1**********',

    base:'http://www.jotform.com/',

    windowTitle:'Untitled Form',

    background:'#FFA500',

    fontColor:'#FFFFFF',

    type:false,

    height:500,

    width:700

    });

    </script>

    <a id="lightbox-1**********" style="cursor:pointer;color:blue;text-decoration:underline;">Untitled Form</a>

  • Profile Image

    Answered by treetopsbenllech on February 16, 2011 at 10:39 AM

    Hi Sunhuns

     

    Even with this code embeded the light box still appears in the top left corner on IE and partially.  i havent got a URL to show you yet has not unloaded it to my host.

     

    Can you help please?

  • Profile Image
    JotForm Support

    Answered by seyhuns on February 16, 2011 at 10:45 AM

    If you can give me an URL, I could help you more =)

    Please control your DOCTYPE decleration. You should have this code at the top of your page:

    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
  • Profile Image

    Answered by treetopsbenllech on February 16, 2011 at 11:06 AM

    LEGEND THANKS VERY MUCH THATS SORTED IT, THANKS SO MUCH FOR YOUR EXCELLENT REPSONSE TIMES AND HELP

  • Profile Image

    Answered by antoniooi on April 07, 2011 at 06:42 AM

    But that doesn't solve my problem. Below are my conditions:

    1. Feedback button (with Lightbox)

    2. With page break containing 'Next' button.

    3. DOCTYPE declaration:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    Everytime when the 'Next' button is clicked, the form jumps to the top of the screen. To test:

    1. Go to: http://www.multidimension-pg.net/

    2. Click on 'Training Advisor'.

    3. Enter anything and click 'Next'.

    Please help. Thanks!

    Antonio

  • Profile Image

    Answered by mldinspections on April 21, 2011 at 08:27 PM

    oh man I was having the same issue. I solved it with Al Pachino's I mean seyhuns suggestion. thank you so much.

    you rock...........

  • Profile Image
    JotForm Support

    Answered by egeg on April 22, 2011 at 03:57 AM

    @antoniooi: Everything seems fine on my end on Chrome for Mac. Which browser are you using? And it would be great if you can post a screenshot.

  • Profile Image

    Answered by antoniooi on April 22, 2011 at 04:06 AM

    @egeg: I'm using Chrome 10.0.648.205 and Firefox 4. Not working on IE9 either. I suspect that my Blogger's CSS theme screws it up. Everything fine when embed on clean web page.

    To test it at your side:

    1. Go to: http://www.multidimension-pg.net/

    2. Click on 'Launch Advisor!', the green left button.

    3. Enter something and click 'Next'. You will notice that the light box shifted upwards.

    Thanks.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 22, 2011 at 04:15 AM

    @antoniooi

    The "shifting" is caused by the page breaks in your form. That is how page breaks work. It automatically focuses on the top of the form whenever the next button is clicked.

    Sadly, the only way to avoid this is to remove the page breaks.

  • Profile Image

    Answered by antoniooi on April 22, 2011 at 04:19 AM

    @NeilVicente: Well, if you try it on the preview mode or cleam HTML page, it won't. Just try and see. ;-)

    Because of this reason, I suspect it's due my Blogger CSS theme that is causing the problem. But do let me know if you do discover something else. Thanks!

  • Profile Image
    JotForm Support

    Answered by egeg on April 22, 2011 at 04:20 AM

    Oh, i see now. I'll talk to seyhuns to see what we can do about this. Thanks for the input.

  • Profile Image

    Answered by antoniooi on April 22, 2011 at 04:22 AM

    Yup, thanks and appreciate a lot! ^^

  • Profile Image
    JotForm Support

    Answered by seyhuns on April 22, 2011 at 04:31 AM

    @antoniooi: Please try to add the following into your script.

    <script src="//www.jotform.com/min/g=feedback" type="text/javascript">

    new JotformFeedback({

    formId: "1********",

    buttonText: "Launch Advisor!",

    base: "http://www.jotform.com/",

    background:'#4fad16',

    fontColor:'#FFFFFF',

    buttonSide: "left",

    buttonAlign: "center",

    type:2,

    iframeParameters: {noJump: true},

    width: 690,height: 625});

    </script>

  • Profile Image

    Answered by antoniooi on April 22, 2011 at 04:38 AM

    Added the:

    iframeParameters: {noJump: true},

    Still the same. :(

    Tested on both latest Chrome stable version and Firefox 4.

  • Profile Image

    Answered by antoniooi on October 07, 2011 at 04:40 AM

    Hi Guys,

    The jumping issue has been solved. It was actually caused by my target="_blank" href="#". Thousands of apologies! 

    But now, I have another website, still following the advices that you guys given above, but it only works on all other browsers except IE9. The problem is, the feedback button not appear at all and the lightbox totally not poped up after clicking the link. To try out this problem, follow the steps below:

    1. Open your IE9 and go to http://otkwebdesign.blogspot.com/p/pricing.html (please ignore the CSS 3.0 display issues on IE9).

    2. Scroll down to the bottom and click 'Order Now'. Notice that nothing happen.

    3. Try the same on Chrome or Firefox -- it works!

    Please let me know what else that I need to do to fix this problem. Thank you!

    Antonio

  • Profile Image

    Answered by antoniooi on October 07, 2011 at 01:29 PM

    Hi Guys,

    Pertaining to the above post dated October 07, 2011, while I can't wait for your response, I have tentatively changed my lightbox implementation for my 'Order Now' link to a dynamic javascript redirection to a page-embed format based on browser detection. However, the lightbox is still on for other browsers by using this javascript.

    But do let me know once you guys have the solution. Thank you.

    Antonio

  • Profile Image
    JotForm Support

    Answered by liyam on October 08, 2011 at 12:42 AM

    Hello Antonio,

    Sorry about this, is it possible for you to start a new thread instead?  It's because a ticket has been assigned to this and the issue is quite different from this thread.  If you can also provide us a sample page that we can look into, that would be great.

    Thank you.

    Warm regards,

    Liyam

  • Profile Image

    Answered by antoniooi on October 08, 2011 at 04:30 AM
  • Profile Image
    JotForm Support

    Answered by liyam on October 08, 2011 at 05:18 AM

    Thank you, Antonio.