Evaluation Slider Update does not work with calculation values

  • Profile Image
    sharpist
    Asked on February 08, 2018 at 06:23 AM

    I have built a form that converts slider input into text / numbers.

    (Because calculation values for Evaluation Sliders do not seem to work.)

     

    Yet, most of the slider updates are not mirrored in the text / number fields, when going back to the slider and changing the input. Why?

    Example has been setup for first question (Power-1-TEXT + Power-1-NUMBER)

  • Profile Image
    ashwin_d
    Answered on February 08, 2018 at 09:39 AM

    I did check your form and found that you have added "Input Table" filed in form. You have also added condition to check the selected value and inserting the numeric value in another field. 

    Please note that there is a better way to achieve this. You can add "Calculation Values" for each option of of input table and then just read the calculation values of in form calculation widget. Please check the screenshot below on how to add calculation values:

    1518100761calcVal.gif

    Hope this helps.

    Do try it out and get back to us if you have any trouble.

  • Profile Image
    sharpist
    Answered on February 08, 2018 at 10:19 AM

    Dear Ashwin,

    many thanks for your feedback. I know the option you are describing. Yet this did not work for the Evaluation Slider. The Input from the slider is not converted into any values (despite calculation values that I tried earlier).


    Cheers,

    H

  • Profile Image
    ashwin_d
    Answered on February 08, 2018 at 11:49 AM

    Okay I will try out the calculation values option with "Evaluation Slider". Your input table has following columns:

    strongly disagree

    disagree

    rather disagree

    rather agree

    agree

    strongly agree

    I would suggest you to please let us know the calculation values of each of the options and I will test this issue.

    We will wait for your response.


  • Profile Image
    ashwin_d
    Answered on February 09, 2018 at 11:29 AM

    Thank you for sharing the calculation values. I will work on your requirement and get back to you on this soon.

  • Profile Image
    ashwin_d
    Answered on February 11, 2018 at 04:52 AM

    I'm sorry for the trouble caused to you. 

    I did test this issue and there seems to be glitch where the calculation values are not working in "Evaluation Slider" of "Input Table" fields.

    I am reporting it to our backend team. We will get back to you as soon as we have any update from them.

  • Profile Image
    irem
    Answered on February 12, 2018 at 07:02 AM

    Hello,

    We are sorry for the inconvenience caused.

    The problem should be fixed now. Please check your slider output values again and let me know if you need anything further.

    Thank you!

  • Profile Image
    sharpist
    Answered on February 15, 2018 at 05:00 PM

    I am afraid, it does not work. Possibly this fix rather broke my workaround:

    I want my evaluation slider to paste it's value into a second field via a Condition. This paste worked before and is now defunct. Also the auto conversion into a number via Calculation Values does not work.

    (My workaround works in the preview, yet is not working where it's embedded sharpist.webflow.io/motive/test)

    Can you please fix either?

  • Profile Image
    John_Benson
    Answered on February 15, 2018 at 07:44 PM

    To my understanding, it is working properly in the form direct link but it is not working when you embed the form to the link you provided.

    Is that correct? If yes, I checked the link (sharpist.webflow.io/motive/test) and I was not able to investigate it further because the page is not working. Here's the error message:

    151874132832513.png

    Please try re-embedding the form using the iFrame Method. Here's a guide: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    If the issue still persists, please provide the working website link so we can check it further.

    Thank you.



  • Profile Image
    sharpist
    Answered on February 16, 2018 at 02:57 AM

    Sorry, this was a typo. It is embedded in an iFrame here and not working: http://sharpist.webflow.io/motive-test

  • Profile Image
    ashwin_d
    Answered on February 16, 2018 at 04:17 AM

    I am sorry for the trouble caused to you. I am reporting it to the assigned developer. We will get back to you as soon as we have any update on this.

  • Profile Image
    irem
    Answered on February 16, 2018 at 08:16 AM

    Hello,

    We are sorry for the inconvenience.

    The problem should be fixed. If you encounter this issue again please try to re-create and save field calculations and let me know if you need anything.

    Thank you for contacting us!

  • Profile Image
    sharpist
    Answered on February 16, 2018 at 09:36 AM

    Hey, it works on desktop now – yet not on mobile (iPhone 8, iOS 11, Safari + Chrome).

  • Profile Image
    ashwin_d
    Answered on February 16, 2018 at 11:00 AM

    I did test issue in and I am able to replicate it. The calculation values in input table fields displayed correctly in form calculation widget when tested on computer but calculation in same form does not work when form is accessed from mobile device. 

    I am reporting it to the assigned developer. We will get back to you as soon as we have any update on this issue. 

  • Profile Image
    ashwin_d
    Answered on February 17, 2018 at 10:22 AM

    I would suggest you to please clear your form cache and should solve your problem. The following guide should help you how to clear form cache:  https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache 

    Please clear your form cache and then test your form in mobile device, it should work as expected.

  • Profile Image
    sharpist
    Answered on February 19, 2018 at 08:24 AM

    I cleared the cache, I does not work. Will it ever?

    Quite frankly, this is really annoying. I had already found a workaround that was fine ... your fixes apparently broke the workaround. Any chance, you will fix this for good or would you advise me to seek another form service?

  • Profile Image
    irem
    Answered on February 20, 2018 at 07:50 AM

    Hello again,

    We are really sorry for the inconvenience caused. We've missed something about the problem.

    Could you please confirm that it is fixed now?

    Thank you for your patience and cooperation.

  • Profile Image
    sharpist
    Answered on February 20, 2018 at 10:36 AM

    It has not been fixed, I simply chose another input method on my webpage. The broken form still exists here: https://form.jotformeu.com/80374557307359

  • Profile Image
    John_Benson
    Answered on February 20, 2018 at 11:33 AM

    I cleared your form cache on our server. After that, I did a test submission to your form (https://form.jotformeu.com/80374557307359) using a desktop. Here's the result:

    15191440365v13v43.png

    I choose 4 agree and 8 very important to me. I checked our mail logs and here's the calculation result:

    15191440794cd2c2134f.png

    Could you please test it again and see if the issue still persists? 


  • Profile Image
    sharpist
    Answered on February 20, 2018 at 11:41 AM

    Now it works, thank you!