Unable to see email field on GetResponse Integration

  • Profile Image
    rosjam
    Asked on February 20, 2018 at 07:19 PM

    Doesn't seem to be working. Please advise. 

  • Profile Image
    Ryan_Briones
    Answered on February 20, 2018 at 10:10 PM

    I’m sorry for that. Let me help you. 

    I tested the integration on my form and it works fine. What specific error are you getting? 

    1519182411getresponse.pngCan you make sure that you entered the correct API? In case you didn’t know, you can use your existing API or create a new one by logging into your GetResponse account. 

    1519182644Email Marketing, AutoresponderAre you able to view your lists? Can you also check the email address?

    When the form is submitted, GetResponse typically sends an email to the email address on your form. Please check if you entered a working email address to confirm the subscription.

    Here’s a relevant thread which you might find useful: https://www.jotform.com/answers/736629-Jotform-Data-is-not-transferring-to-my-Getresponse-Campaign

    Guide: How to Integrate Forms with GetResponse 

  • Profile Image
    jennietodd141
    Answered on February 20, 2018 at 11:59 PM

    It's really nice and meaningful.

     

  • Profile Image
    rosjam
    Answered on February 21, 2018 at 02:42 AM

    Hello Ryan,

    Thanks for the response. 

    So I am able to add the API. I'm also able to choose the list.

    However, when I choose the downward arrow next to email. It's not giving me any options. 


    1519198921jotform.jpg

  • Profile Image
    Kiran
    Answered on February 21, 2018 at 06:19 AM

    I believe that you are referring to the form https://www.jotform.com/80458019684161 in your account. As I check your JotForm, I notice that there is no email address field on the form. Please add the email address field to the form so that the same should be displaying in the GetResponse integration window.

    1519211946Selection_111.png

    Hope this information helps!

  • Profile Image
    rosjam
    Answered on February 21, 2018 at 10:11 AM

    Hello Kiran,

    I did as you said. I added the email line. It still does not show up in the drop down. I added in the first position of items as well and it still did not work. It's not in the second position as the first is set to ask for Name, then email.

    Not sure what I'm doing wrong?

  • Profile Image
    TREVON
    Answered on February 21, 2018 at 11:27 AM

    I checked your form and I could see the email field has now been added. I tested integration on your form and I was able to see the email field. In fact I was able to see the fields also as shown below.

    1519230406Screen Shot 2018-02-21 at 19.2

    Kindly try clearing your browser cache and test adding the GetResponse integration to your form. You can also try using another browser to check if you can complete the integration.

    Kindly do let us if you need further assistance.

  • Profile Image
    rosjam
    Answered on February 21, 2018 at 01:48 PM

    Hello Trevon,

    Thanks or the reply.

    I did as you suggested. I did clear cache. I also tried on both Google Chrome and Firefox. I also tried on another computer. The results for me are the same. I do not see the options that you are seeing on your end. The other dropdowns work perfectly, but not the one for email.

    Any other suggestions?

  • Profile Image
    TREVON
    Answered on February 21, 2018 at 02:05 PM

    I have thought of something we may have not considered before. Would you kindly try to create another GetResponse account we can test with and see if this is related to your GetResponse account.

    I have thought of this because with my account I am able to see these fields and with your account you are not.

    Kindly test and do let me know if it works with new account.

  • Profile Image
    rosjam
    Answered on February 21, 2018 at 02:23 PM

    Just FYI. I tried the same process for ZOHO and it also doesn't work. I checked the 8 reviews for the Zoho integration and 3 people have the very same issue. That's a total of 4 separate Getresponse accounts not populating the email portion of the API integration.

    Doesn't seem to be a GR issue. 

  • Profile Image
    liyam
    Answered on February 21, 2018 at 03:56 PM

    Hello rosjam,

    Just to be sure, can you confirm with us if Kiran had the correct form which you are experiencing the issue or it is something else? Can you share with us the link to the form which you are currently working on?

    Thanks.

  • Profile Image
    rosjam
    Answered on February 21, 2018 at 04:06 PM

    Yes, he had the correct form link. Name is changed now, but it's the same form. 


    https://form.jotform.com/rosjam/credit-assessment


  • Profile Image
    Richie_P
    Answered on February 21, 2018 at 05:30 PM

    I cloned your form and I can't seem to replicate the issue.

    The email address field is showing on my integration.

    I tested the cloned form and I successfully received the submission to my get response integration.

    Can you try my colleagues suggestion in creating a new get response account and see if the issue still remains.

    Thank you.