Submit button is stuck on "Please wait"

  • Profile Image
    halston6
    Asked on March 13, 2018 at 06:31 AM

    I’ve tried updating the widgets as per some of the other issues I’ve seen people having with the “please wait” and it’s still stuck. This form was working and is a recent issue. Thank you for your time.

  • Profile Image
    Rose
    Answered on March 13, 2018 at 10:05 AM

    We are sorry for this inconvenience.

    I've tested your form on Chrome and I wasn't able to replicate the problem on my end. As you can see here, I was able to submit your form.

    1520949740Screen Shot 2018-03-13 at 17.1

    Could you please tell us on which browser you are experiencing this problem? Please also try after clearing your browser caches. 

    In addition to this, if the problem is happening on an embedded form, please send us the direct URL of the webpage where your form has been embedded. 

  • Profile Image
    halston6
    Answered on March 13, 2018 at 10:26 AM

    I just tested on Safari, Firefox and Opera and am experiencing the same issue on all of them.

  • Profile Image
    aubreybourke
    Answered on March 13, 2018 at 12:33 PM

    I was able to reproduce the problem with Chrome and MS Edge:

    1520956964vem0x.png

    I tested your form and found the problem is due to requiring the address field. If you unrequire the address field your form will work.

    1520958986lw0bc.png

     

  • Profile Image
    halston6
    Answered on March 13, 2018 at 01:59 PM

    Aubreybourke thank you that fixed it!