Conditions not working to navigate the pages

  • Profile Image
    jcacagility
    Asked on March 15, 2018 at 07:05 PM

    Conditions are not working and the form won't navigate to the next page 

  • Profile Image
    Kiran
    Answered on March 15, 2018 at 10:38 PM

    I am able to replicate the issue at my end with the cloned version of your JotForm. The issue doesn't seem to be with the conditions, since I am unable to navigate to the next page even after disabling all the conditions on the form. Please allow me some to investigate the issue further and get back to you with relevant information.

    Thank you for your patience.

  • Profile Image
    Kiran
    Answered on March 15, 2018 at 10:59 PM

    I have checked the form further and see that the issue with the payment field. I notice that there are 5 products listed in the payment while the form is displaying only 4 products.

    1521168754Selection_093.png 1521168773Selection_092.png

    I have tried editing the product name on the form thinking ! symbol could be causing the issue. As I remove the exclamatory symbol from the product name, it is displayed on the form on the form which resolved the issue. However, when I try to add it again to the product I am again unable to replicate the issue and all the 5 products are displayed normally on your form as well. The issue seems to be a temporary glitch or a conflict with some other field that I cannot replicate the issue anymore.

    Please check and let us know if you notice any further issue. We will be happy to help.