File Upload: Having some issues with the image upload

  • Profile Image
    Miriam85044
    Asked on March 16, 2018 at 01:05 PM
    The other form in step #1 has apparently been having some issues with the image upload as well.
  • Profile Image
    gizem
    Answered on March 16, 2018 at 01:46 PM

    I have checked your form (https://form.jotform.com/80557319147158).

    I did not encounter any problems with uploading the image to your form:

    15212219382.gif

    Could you please ask people who encounter the problem that which device and browser are they using for this form, too?

    Which kind of problems are they having?

    Is there an error in the browser's console? This guide can help you about how to get a console report from your browser.

    If we can replicate the problem, we can open a bug for that.

  • Profile Image
    Miriam85044
    Answered on March 20, 2018 at 07:43 PM
    I had at least 5 people – almost every user – complaining about similar issues. 3 people gave me further detail….see below.
    I am really upset that this is occurring. You tell me that this form is working fine. Clearly – it is NOT. I pay good money for your software and expect it to work much better and more reliably than free form services that are out there. And right now, that’s not the case.
    Please advise what is going on here!!!!
    User 1
    I've tried about 15 times to get the images to upload, and it doesn't work. I'm using a Mac. Using Google Chrome. On each screen, the images say they are uploaded successfully, but at the end it throws an error and takes me back to the images.
    User 2
    * My problem occurred after filling out all 45 or so of the fields, right after I clicked on the “I’m not a robot." I was reviewing the submission form - maybe editing a description field. Everything was lost - gone. I could not go back to any part of the form. I had to re-start the process the next day from the beginning, and that time it was fine. (But I was scared of going backwards!!!!!)
    * I was using my new MacBook Pro, High Sierra, 10.13.3 / Safari.
    User 3
    * I was using Microsoft Edge on a PC and Chrome.
    * My problem was trying to upload the headshot. When I used the browse function to look at my files and choose the file to upload it showed the file uploaded but when I went to submit the application it showed an error stating that no headshot was uploaded. When I went back to that step the file showed that it was there but it wouldn’t upload. Tried making the image smaller deleting the file and reuploading but still got the same error. Finally tried dragging and dropping and then it worked.
    * Just as an aside every time the application submission didn’t go through it would delete the location from the location field on the address step. So I would have to go back and refill out the address page.
    * Once I knew to drag and drop the second part of the application where I uploaded images of my art went very smoothly!
    ...
  • Profile Image
    Kiran
    Answered on March 20, 2018 at 10:27 PM

    We are sorry for the inconvenience this may have caused. I have tried submitting your JotForm on two different environments (Linux and MacOS) and was not able to replicate the issue at my end. The two submissions were submitted normally and displayed the thank you page without any issue. 

    Is the form embedded on any of your web pages and experiencing the issue from the web page? If so, please provide us with the web page URL where the form is embedded so that we can take a look and try to replicate the issue to assist you further. Also, were you able to replicate the issue at your end? If so, a screenshot of the error message could help us in investigating the issue.

    Thanks!

  • Profile Image
    Miriam85044
    Answered on March 23, 2018 at 02:43 PM
    This is the form that I am referring to. https://form.jotform.com/80537343147153
    It is located on this page: http://www.az-artisanscollective.com/ggrfp.html
    This is at least the second time I’ve sent this information with the links. No – I have not replicated the issue. But I am really unhappy to hear that there is no idea at all what might be causing the issue with multiple users… I am VERY frustrated. I’d really prefer to speak to someone rather than have this drawn out email exchange that is getting us nowhere.
    This is clearly an issue and it is impacting my business. I need some help getting this resolved!!
    Please advise ASAP. Thank you,
    Miriam
    ...
  • Profile Image
    Richie_P
    Answered on March 23, 2018 at 03:51 PM

    We are sorry for the inconvenience this may have caused you. Unfortunately, we cannot replicate the issue at our end.

    We understand your frustration, I have read the information given by your customers and tried to follow their steps but still, I was not able to replicate the issue.

    Can you please let us know, what error/s are thrown when your customers uploaded the file?

    Thank you.


  • Profile Image
    Miriam85044
    Answered on March 27, 2018 at 04:43 PM
    This CONTINUES to happen (see email below) with multiple forms. There is ZERO error message. I am running a business. And currently I feel that without further resolution on this I may need to cancel my subscription and find another, more reliable forms solution. I have asked to speak with someone to get this resolved as there has been no progress. You have a major issue with your forms and NOBODY there is doing anything concrete to resolve it. I am incredibly frustrated and previously was a very happy customer. Not good!!
    ~Miriam Carlson-Maier
    ...
  • Profile Image
    BDAVID
    Answered on March 27, 2018 at 06:14 PM

    Probably the issue is related to the upload size limit, or the allowed file types:

    1522188658limitfilesize.png

    I would recommend you to increase the upload size limit: https://www.jotform.com/help/33-Changing-the-File-Upload-Size-Limit 

    Clearing your forms cache: https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache 

    Please update us if the issue with the file upload field. Just to let you know, I have also forwarded this case to our developer, so they can check and try to reproduce the issue with the File Upload field.

  • Profile Image
    burak
    Answered on April 05, 2018 at 11:43 AM

    Hello, 

    This problem should have been fixed due to our recent developments. Are your users still experiencing this misbehavior? 

  • Profile Image
    Miriam85044
    Answered on June 13, 2018 at 08:43 PM
    It is not fixed. I have a customer who is unable to submit his form – see attached error message. And the image showing that there is in fact an image attached so the error is invalid. He cannot proceed. PLEASE ADVISE.
    ...
  • Profile Image
    BDAVID
    Answered on June 13, 2018 at 10:05 PM

    Your screenshot did not post to this thread. Please try again: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 

    Also, please try clearing your forms cache: https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache 

  • Profile Image
    Miriam85044
    Answered on June 14, 2018 at 04:21 PM

    Hello,

    So yes I have now cleared the forms cache.  

    And I am attaching the screen shots here.  There is a file attached, yet he gets an error message when trying to submit.  

    I have since, just now, also gone in to eliminate the file size limitation although I don't think that was the issue since it did in fact upload his headshot image.

    1529007608johnheadshot.jpg


    1529007517johnerror.jpg

  • Profile Image
    jonathan
    Answered on June 14, 2018 at 05:03 PM

    I believe the error that was shown in your screenshot image was a validation error only.


    1529009574zzz 2018-06-15 04.50.13.png

    Meaning there were *required questions on the form that were not yet answered and the user tried submitting the form already.

    That can be fix by reviewing the form answers and make sure all required/mandatory question have answers to them. After that, submission should be as normal.

    ---

    I did test submitted your form https://www.jotform.us/form/80557319147158 also.

    And I was not able to encounter any problem with the Uploading of photo and as well us the validation error at the end. I was able to submit the form completely without any issue at that time.

    1529009929zzz 2018-06-15 04.46.30.png


    1529009881zzz 2018-06-15 04.48.38.png

    1529009954zzz 2018-06-15 04.48.55.png


    You can search your form submission page using my test submission ID# 4048185292716425298  or the uploaded file name J C M Copy.jpg so you can verify the completed submission.

    User guide: How to Search a Submission from the Submissions Page

    You can delete my test submission so it will not add up to your form submission count.

    Let us know if issue persist.