User's submissions can only be seen using the EU server

  • Profile Image
    HWX
    Asked on March 19, 2018 at 01:59 PM

    Hi,

     

    Up until this morning, our API has stopped working. Could our API key have expired? We feed data to Jotform from our POS system. We're getting a submission ID, but all fields are blank on all of our forms and I'm not sure why. 

  • Profile Image
    Richie_P
    Answered on March 19, 2018 at 03:28 PM

    I cloned your form and I can't seem to replicate the issue.

    Further investigation, I have found out that you can access your form submissions using https://eu.jotform.com, kindly try to use https://eu-api.jotform.com/ and let us know how it goes.



  • Profile Image
    HWX
    Answered on March 19, 2018 at 04:04 PM

    This is what appears in my http log after I send data from my POS system to Jotform. It looks like I'm getting an "OK" response, but there's no data in the form when I navigate to it. Here's the log and submission URL below:

    https://www.jotform.com/form.php?mode=inlineEdit&formID=80585956613164&sid=3972989110122755775

    ---- Sending ----

    POST /form/80585956613164/submissions HTTP/1.1

    Content-Type: application/jsonrequest

    Accept: application/json

    Content-Encoding: identity

    Connection: keep-alive

    User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

    Accept-Language: en-us,en;q=0.5

    apikey: 0220548d78f668da73e52c8cffcaec0b

    Accept-Encoding: gzip

    Host: api.jotform.com

    Content-Length: 145


    {"3":"9195","4":"ALYSSA","5":"FINK","6":"03/19/18","9":"","10":"","11":"","12":"","13":"","14":"5048989898","16":"test@test.com","24":"03/19/18"}

    ---- Received ----

    HTTP/1.1 200 OK

    Server: nginx

    Date: Mon, 19 Mar 2018 20:01:51 GMT

    Content-Type: application/json

    Vary: Accept-Encoding

    Set-Cookie: PHPSESSID=2topaaggsva56qutujoqohg1s2; path=/; domain=.jotform.com

    Set-Cookie: jcmc=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; domain=.jotform.com

    Set-Cookie: jcmc=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/

    Set-Cookie: jcm=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; domain=.jotform.com

    Set-Cookie: jcm=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/

    Set-Cookie: theme=tile-black; expires=Thu, 19-Apr-2018 20:01:51 GMT; Max-Age=2678400; path=/; domain=.jotform.com; secure; HttpOnly

    Set-Cookie: guest=guest_80776194761063; expires=Thu, 19-Apr-2018 20:01:51 GMT; Max-Age=2678400; path=/; domain=.jotform.com; secure; HttpOnly

    P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"

    Expires: Thu, 01 Jan 1970 00:00:01 GMT

    Last-Modified: Mon, 19 Mar 2018 20:01:51 GMT

    Cache-Control: no-cache

    Pragma: no-cache

    Access-Control-Allow-Methods: PUT, POST, GET, OPTIONS, DELETE

    Access-Control-Allow-Origin: *

    X-Form-Cache: MISS

    Content-Encoding: gzip

    Via: 1.1 google

    Alt-Svc: clear

    Transfer-Encoding: chunked


    00000001

    0001

    ã

    a2

    mç1Ç0ÑˇÀõ+Ö"©e’≈ƒ…ƒ≠ñ¢%¥%º«D¯Ô>'«ª˚ÓnÉ≈„ú˙sÓ=¥™,DèÿΩXÆŒ±.'Ú↛ÿ|∆Är∫^ò©çVÊd™™¨î“M£u√¸„~„ÏM4∑VZŸÕ°3

    yâÖÀ— àïˇvS

    0001

    ã

    a2

    mç1Ç0ÑˇÀõ+Ö"©e’≈ƒ…ƒ≠ñ¢%¥%º«D¯Ô>'«ª˚ÓnÉ≈„ú˙sÓ=¥™,DèÿΩXÆŒ±.'Ú↛ÿ|∆Är∫^ò©çVÊd™™¨î“M£u√¸„~„ÏM4∑VZŸÕ°3

    yâÖÀ— àïˇvS0001

    ã

    a2

    mç1Ç0ÑˇÀõ+Ö"©e’≈ƒ…ƒ≠ñ¢%¥%º«D¯Ô>'«ª˚ÓnÉ≈„ú˙sÓ=¥™,DèÿΩXÆŒ±.'Ú↛ÿ|∆Är∫^ò©çVÊd™™¨î“M£u√¸„~„ÏM4∑VZŸÕ°3

    yâÖÀ— àïˇvS

    a2

    mç1Ç0ÑˇÀõ+Ö"©e’≈ƒ…ƒ≠ñ¢%¥%º«D¯Ô>'«ª˚ÓnÉ≈„ú˙sÓ=¥™,DèÿΩXÆŒ±.'Ú↛ÿ|∆Är∫^ò©çVÊd™™¨î“M£u√¸„~„ÏM4∑VZŸÕ°3

    yâÖÀ— àïˇvSa2

    mç1Ç0ÑˇÀõ+Ö"©e’≈ƒ…ƒ≠ñ¢%¥%º«D¯Ô>'«ª˚ÓnÉ≈„ú˙sÓ=¥™,DèÿΩXÆŒ±.'Ú↛ÿ|∆Är∫^ò©çVÊd™™¨î“M£u√¸„~„ÏM4∑VZŸÕ°3

    yâÖÀ— àïˇvSàÅ쯒ò£–ØKG\˘æ÷aˇÓ∑åø

    0


  • Profile Image
    Richie_P
    Answered on March 19, 2018 at 04:44 PM

    I have changed your link into https://eu.jotform.com/form.php?mode=inlineEdit&formID=80585956613164&sid=3972989110122755775

    I have used https://eu.jotform.com and I can see the data on the submissions.

    If you have further questions about API, you can contact our API team for further assistance on that matter. Send them an email at api@jotform.com

  • Profile Image
    HWX
    Answered on March 19, 2018 at 04:51 PM

    Can we get this fixed without having to change the url to eu.jotform.com......? 

    I don't know why it's suddenly not working, we've been using the format that I provided for several months now. If we can't get it to work the way it has been, I'll need to bring our software developer on so that he can modify the code. Please let me know if we can fix this before we have to go that route.

    I'll reach out to the API team as well.


  • Profile Image
    Richie_P
    Answered on March 19, 2018 at 05:46 PM

    After checking your account, it seems you are not in the EU region. I also have checked your datacenter and you have not moved your data into the EU datacenter.

    I will forward this issue to our next level so that they can check it our further.

    We will let you know via this thread if updates are available.

  • Profile Image
    HWX
    Answered on March 20, 2018 at 10:34 AM

    Thanks for your help! This issue was resolved :)