Google Drive integration worked, then failed, now won't work when re-integrated

  • Profile Image
    nfusso
    Asked on March 19, 2018 at 05:08 PM

    TL;DR: I cannot get my Google Drive integration to work, even after going through a re-integration and cache clearing process. Any ideas on what I can do? 

    A while ago (years?), I created a form and setup Google Sheet and Google Drive integrations. This worked very well until just recently (perhaps in January 2018). Around this time, I realized that the Google Drive integration no longer seemed to work. The Google Sheet integration was fine, meaning that form data was still captured in a spreadsheet. However, the form PDF and attachments were no longer appearing in my Google Drive folder. 

    I researched solutions on the JotForm (for instance, here: https://www.jotform.com/answers/933989-My-integrations-with-drive-and-google-sheets-are-not-working-) and implemented the solutions suggested:

    1) I removed the original Google Drive integration
    2) I cleared my browser cache 
    3) I re-integrated with Google Drive

    This solution failed to create a visible Drive integration.
    -- When I click the link provided on my Settings>Integration page, I am navigated to a new Google Drive tab. I then receive an error in a pop up window from Google stating "Can't find folder. This folder either doesn't exist or you do not have permission to access it".

    I then tried a test submission, as I read that the integration is only visible after new form data is submitted. I also double checked that the integration was setup using the proper Google account. However, these solutions failed as well, and I experience the same error. 

    >>Any ideas on how I can re-integrate Google drive, from an existing form, and to an existing folder?

  • Profile Image
    Jed_C
    Answered on March 19, 2018 at 07:02 PM

    We apologize for the inconvenience.

    I just tested Google Drive integration and it works from my end.

    1521500309gdrive_integration.png

    When integrating to your Google Drive, are you selecting the main folder or sub-folder folder? Also, have you tried integrating a new form or another form just to rule out whether this issue is isolated to one form only? I was wondering if the error "Can't find folder" only happens with this form https://form.jotform.com/50645575837971?

    I would really help us if you can provide us a screencast using this tool https://screencast-o-matic.com/screen_recorder so we can see the steps you took on how you reproduce it.

    Looking forward for your response.