Form field is being blanked out when submission is edited

  • Profile Image
    bluefiregroup
    Asked on March 25, 2018 at 11:17 PM

    Hi - I am really struggling with this one!

    One of the very first fields in my form is "Your Name / Account Name"

    It's a required field on the very first page. It can be filled in manually or if other systems are used (prior to the form) it can be filled in using a preset values from another field (and I have tested this and it seems to have no impact on this issue).

    We have noticed that although the fields is always showing as filled-in on the submission table, when we EDIT the form again its being BLANKED out.
    e.g. https://www.screencast.com/t/5bMkctYiM

    We see it filled in on the jotform for the first edit - but then the 2nd time the submission is edited, it gets blanked out (but it still shows as filled-in in the submission table). This problem is seen by me, my staff and clients too - so we don't think this is environment related.

    What's interesting is that you can see the value being posted into the field on the jotform - but then almost instantly it gets blanked out - like a rule or something is triggering and causing this to happen - but I am unable to see any of my conditions that might do this!

    We are at a loss as to what is causing this - any help would be greatly appreciated!

    Thank you!



  • Profile Image
    tina
    Answered on March 26, 2018 at 06:31 AM

    I have cloned and tested your form, and I was able to replicate the issue as you can see on the gif given below:

    1522058601new224.gif

    However, I noticed some conditional issues which cause the problem you have mentioned.

    -> There are some conditions about "Your Name" field. It seems you have never set any value to "Your Name" field but also you have set a condition that sets the value of the empty  "Your Name" field to "Your Name / Account Name". Therefore, the "Your Name / Account Name" value appears when the form first loads and then it seems to be disappeared since the value of the empty "Your Name" field is attempted to set into "Your Name / Account Name". 

    1522054711Screen Shot 2018-03-26 at 11.4

    I have tried to fix the logic with a new condition and disabled the old one. You can try and test the cloned form and please do not hesitate to clone if you need to:

    1522055152Screen Shot 2018-03-26 at 12.0

    The clone form:

    https://form.jotform.com/80842462923964

    How to Clone an Existing Form from a URL

    I hope it helps.

  • Profile Image
    bluefiregroup
    Answered on March 26, 2018 at 03:01 PM

    Tina - thanks for taking a look at this. I understand what you have done.

    However, the condition said that ONLY if "Your Name" IS FILLED should it copy the value to the other field. .... and the default value on that field is empty.
    So the condition should never get executed as long as "Your Name" is empty.

    So, why is the condition executing if the "Your Name" field is empty (i.e. not filled)??
    What exactly does "IS FILLED" mean?

    thank you for your help!

  • Profile Image
    Adrian
    Answered on March 26, 2018 at 04:40 PM

    I have cloned your form but I was not able to replicate the issue.

    15220960851.png

    Can you please test this again and see if it persists.

    The condition should not be triggered unless the "Your Name" field has a value.

    Can you please try if this is happening when you edit the submission from the Submissions Page as well?

    How to Edit Submissions Made on Your Forms

  • Profile Image
    bluefiregroup
    Answered on March 27, 2018 at 06:46 PM

    Hi Adrian - the issue persists. When I tested it again just now, the form field is being blanked out now on the first Edit. I have tested in multiple browsers and incognito mode to check no browser extensions are interfering.

    I looked at several form submissions on the Submissions Page - they all display the same issue

    here is screenshot showing that the submission has the "Your Name / Account Name" filled in - yet the form field shows this as blank.

    15221904372018-03-27_16-40-09.jpg



  • Profile Image
    John_Benson
    Answered on March 27, 2018 at 09:21 PM

    Hi,

    I submitted a test submission to your form and I was not able to replicate the issue. Here's a screen capture of your Thank You page and then I open the Edit Submission link:

    1522199959Test_edit_link.gif

    Please try this, fill up the form using Incognito Mode and do not log in to your account (form owner). After that, try editing the submission.

    Let us know if the issue still persist.

  • Profile Image
    bluefiregroup
    Answered on March 27, 2018 at 10:03 PM

    Hi John - thanks for looking at this.

    You may want to go back to edit a couple of times - not just once. Initially I found that the first edit was fine - and the issue occurred on the second edit - but honestly I think it's random - but I always end up with the issue.

    I actually created a clone and preset the "Your Name:" field to X and changed the rule so that if  "Your Name:" was not equal to X then copy to "Your name / Account name" - but this had no effect - the field still keeps blanking out!

    Its very odd.

    If I remove that one rule then it seems to works fine

  • Profile Image
    bluefiregroup
    Answered on March 27, 2018 at 10:26 PM

    I am modifying the form to eliminate the use of the test I have currently.

    Thanks for all your help

    I did create a clone which has a modified rule that is even more obvious - the form is 
    https://form.jotform.com/80857143177159

    - this still has the same issue. 

    But I have decided at this stage to get into production with an alternative approach.

  • Profile Image
    bluefiregroup
    Answered on March 28, 2018 at 12:35 AM

    UPDATE - SAME PROBLEM - new field

    I think I am cursed!
    I am wondering - did Jotform make a collection of adjustments in the last 12 to 18 months...? This form was working brilliantly for the last 2 years. But now it seems to have problems after some very minor adjustments I made a month or so ago. It's almost as if when I edited the form, it triggered an update of the form system to a new version or something like this (I am pretty certain I was using the OLD editing form-builder method when this form was working correctly..)

    I am seeing exactly the same problem as previously reported, but with a new field.
    Here is the form (without the fields discussed above)

    https://form.jotform.com/bluefiregroup/website-requirements

    The problem field is the last one on page-1

    1. The last field on page-1 is "Select Your theme". I choose Cornwall. Click NEXT
    2. Page-2 now requires that you Check "confirm choice of this theme"
    3. Skip to end and SAVE+ EXIT

    Now "Edit Submission"

    The foot of page-1 now displays a new field saying "Your Selected Theme is:"
    And it should say "Cornwall" in red.
    But again, I am seeing it flash up - (in red as this is read only)
    And then get blanked out

    See below - I Edit Submission .. then scroll down very fast to that field - you will see it quickly flash in red and then blank out...

    15222115602018-03-27_22-31-58.gif

     

    I tested on chrome and Edge and Firefox. On chrome I am logged out and cleared the cache to remove old javascript etc.

    Here's my theory...: 
    There is a condition - just like in the earlier reported issue - that looks at the "Select Your Theme" field - and "if filled", copies this to the "Your Selected Theme is:" field.
    It seems to me that the IF statement checking STATE = ...  is generally not working. In the previous situation, and this one, it was STATE = IS FILLED
    But I did change that to be prefilled with a character 'X" and change the test to be "is not equal to "X"... but it didn't make any difference.

    This is the second time on the same form where this condition seems to be failing or causing this corruption.
    In the first case, as mentioned above, I have actually deleted the IF statement and created a workaround. But in this case I need this to work.

    Looking forward to hearing any ideas on this!

  • Profile Image
    tina
    Answered on March 28, 2018 at 04:10 AM

    I have split your latest post into a new thread in order to assist you better in this regard. You can reach the new thread by clicking this link given below:

    https://www.jotform.com/answers/1428010