Card Forms: Form is crashing up and closing browser while using a mobile device.

  • Profile Image
    MIWgroup
    Asked on March 26, 2018 at 10:35 PM

    Hi

    Please try this form on your cell. And on the question #19, it doesn't let you go forward even though you filled out. I didn't have any problem on the desktops.

    Some users complain after a few tries they got to the end,and try to submit, it doesn't let them submit. Only happens on mobile submission.

    Can't find out why and solution?


    Thank you!


  • Profile Image
    Kiran
    Answered on March 27, 2018 at 05:03 AM

    I have checked your JotForm on my Android mobile and I was able to replicate the issue with the form. As I check the form, i notice that you have set two different conditions for some fields to hide and unrequire the fields. Please be noted that when the fields are hidden, they will be automatically set to unrequired and it is not set another condition to unrequire the fields. You may remove/disable these unrequire conditions from the form. 


    Also, please try disabling the Required option for the Employer Address 1 field and then enable it to see if that works. Let us know if the issue still persists. We will be happy to take a look again. 

  • Profile Image
    Kevin_G
    Answered on March 27, 2018 at 12:47 PM

    I have been testing your form on a cloned version on my end, I was able to get it working after disabling the "Show/Hide" conditions on your form, I have then tried to set up "Show/Hide" conditions based on the same address field and I was unable to replicate the issue on my end. 

    May you please kindly try doing the following? 

    1. Disable all the conditions related to those fields, even those showing/hiding the address fields. 

    2. Test your form using a mobile device and see if the issue persists. 

    Please let us know how it goes. 

  • Profile Image
    MIWgroup
    Answered on March 29, 2018 at 09:34 AM

    Kevin

    I tried all that. I disabled conditions related to the problematic questions. If you go to the problematic questions directly using the short cut guide that you have on the bottom of the form (Employer Address 1, Employer Address 2 (35) , School Address (49) and School Address (54)), you can go through with no problems.  But when you start the application answering one by one from the top, even if you filled all, but still gives me "This question is required" and don't let you go next questions.

    I even turned off all conditions. Now it is giving me the same behaviors.

    It often crashes at the beginning of "Employer History" section.

    I'm testing with iPhone 6 Plus.

    I need a quick solution.  Please help me!

    https://form.jotform.com/80858277784172

  • Profile Image
    Kevin_G
    Answered on March 29, 2018 at 11:23 AM

    I have checked your form and I can see you have indeed disabled all the conditions, I have been testing a cloned form of yours and I can see the issue you're reporting, the form is now crashing when you reach the "Employment history" section. 

    I will pass this thread to our second level so our developers can have a look on this, we will keep you updated via this thread. 

    Thanks. 

  • Profile Image
    MIWgroup
    Answered on April 02, 2018 at 10:54 AM

    How are you doing with this issue?  A lot of failure reports has come if for this issue.  I hope that I hear from you sometime soon.

  • Profile Image
    Kiran
    Answered on April 02, 2018 at 11:02 AM

    We are sorry for the trouble caused. Unfortunately, there is no update yet on this issue from our backend team. If there is any news, we'll update you on this thread.

    Thank you for your patience and understanding. 

  • Profile Image
    MIWgroup
    Answered on April 04, 2018 at 02:05 PM

    It's something to do with your FORM ELEMENT "Address".  I changed with your QUICK ELEMENTS "Long Text Entry".  And the problems that I had before with ADDRESS entries. I would like you to keep investigating the issue but I would like to report that the current configuration seem to work fo now.

    https://form.jotform.com/80745783151157


    Best,


    N

  • Profile Image
    Kevin_G
    Answered on April 04, 2018 at 02:14 PM

    Thank you for your update, I will pass this to the ticket on our second level. 

    The ticket will stay opened and we will keep you updated via this thread. 

    Thanks. 

  • Profile Image
    MIWgroup
    Answered on April 06, 2018 at 10:46 AM

    On mobile only: I have to publish all forms that I'm managing for now with the solutions I described above. Those still often crash on the section breaks. Please fix the problem quick.

    test form:

    https://form.jotform.com/80745783151157

  • Profile Image
    Kiran
    Answered on April 06, 2018 at 11:51 AM

    Let me send a note to our backend team to see if there is any update for you. If there is any news, you'll be updated here.

    Thank you for your patience and understanding. 

  • Profile Image
    MIWgroup
    Answered on April 17, 2018 at 10:47 AM

    Hi

    It's been a while. Is there any update for this issue yet?

  • Profile Image
    Kevin_G
    Answered on April 17, 2018 at 11:20 AM

    Unfortunately, we have not received any update regarding this ticket, the ticket is still opened and the assigned developer working on it. 

    We  will let you know as soon as we receive any updates regarding this. 

    Thanks.