Payment field > Coupon code: Pre-populating the field no longer works

  • Profile Image
    TantrumTheatre
    Asked on April 05, 2018 at 03:18 AM

    Hi there,

    A scrolling issue with pre-populated forms (https://www.jotform.com/answers/1313535-Form-preloaded-by-URL-is-scrolling-to-bottom#2) was previously fixed for us, but the html reference format "https://form.jotform.com/EXAMPLEFORM?coupon-input=EXAMPLECODE" now no longer pre-populates the form.

    Ie. - https://form.jotform.com/73368753625971?coupon-input=EARLYBIRD
    This html reference previously would pre-populate our form with the coupon code EARLYBIRD.

    How should we use a html reference to pre-populate the coupon code?

    Thanks for your assistance.

  • Profile Image
    liyam
    Answered on April 05, 2018 at 06:23 AM

    Thank you for reporting this matter to us, TantrumTheatre.

    I have escalated this to the development team. We will keep you posted once we have updates.

  • Profile Image
    TantrumTheatre
    Answered on April 09, 2018 at 02:13 AM

    Hi,

    Thank you.

    3 of our forms are now working as expected using the pre-populated html reference.
    Unfortunately, the other 2 forms that use this coupon code and are linked using the same reference format, no longer work at all regardless of using the coupon-input reference or not.
    When the form is filled out, and the "submit" button is pressed, nothing happens.

    - https://form.jotform.com/73368753625971?coupon-input=EARLYBIRD  AND
    - https://form.jotform.com/73368963725975?coupon-input=EARLYBIRD

    Please let me know that this will be fixed promptly, as these forms are live on our website.

    Regards.

  • Profile Image
    Kiran
    Answered on April 09, 2018 at 07:50 AM

    The issue related to the coupon code is already been forwarded to our backend team and they'll be looking into. If we have any news in this regard, we'll update you here.

    The other question related to the submit button is moved to a separate thread and shall be addressed there shortly.

    https://www.jotform.com/answers/1438881-Unable-to-submit-the-form

    Thank you!

  • Profile Image
    utku
    Answered on December 12, 2018 at 09:08 AM

    Hi,

    Sorry for my late reply. The issue seems to be resolved. I cloned your form and it worked properly on my tests.

    If issue persists, please inform us
    Thanks.