Braintree Integration: Will not navigate to next page on Card form

  • Profile Image
    shapingdestiny
    Asked on May 22, 2018 at 06:38 PM

    Hello, I have created a Jotform using the new Card template and set up my payment wizard using Braintree. Everything is set up fine but when I try to do a test payment and click "next" after filling out the payment card, nothing happens? How do I fix this?



    This is a re-post of a comment on Introducing JotForm Cards: The Friendly Way to Ask

  • Profile Image
    Kevin_G
    Answered on May 22, 2018 at 08:07 PM

    Apologies for the inconveniences this caused to you. 

    I have been testing with a cloned form of yours and I was able to replicate the issue you mentioned, the problem seems to happen since the form takes a lot of time to load, the problem is actually related to the background image you have added to your form, the image has a large size which makes the form a bit slow. 

    I have removed the image from your from and it worked: https://form.jotform.com/81417715499972 

    You will also need to reduce the size of your image, this tool may help you doing so: https://www.reduceimages.com/ 

    Please note that I'm referring to the size in MB. 

    I hope this helps. 

  • Profile Image
    shapingdestiny
    Answered on May 23, 2018 at 01:06 PM

    Thanks for helping me with this but that solution did not work. The link you sent me says there's a Braintree configuration error so it won't process the payment anyways. I did as you instructed and removed the background image completely but the problem persists. When I get to the portion of entering in the card information and then click "next" nothing happens.

    See the new form:

    https://form.jotform.com/81425461784966

  • Profile Image
    Mike
    Answered on May 23, 2018 at 02:57 PM

    Thank you for provided information.

    We were able to reproduce the issue. A bug report ticket has been escalated to our developers. We will let you know if we have any updates.

    It seems that the Braintree field is working properly when it is the last field of the form. What you can try is to move the Braintree field to the bottom of the form (place it as the last form field).

  • Profile Image
    utku
    Answered on January 31, 2019 at 10:05 AM

    Hi @shapingdestiny,


    I updated your other ticket.

    Inform us if you need further help
    Thanks.