IE blocking CAPTCHA

  • Profile Image
    koiautoparts
    Asked on November 16, 2012 at 03:15 PM

    My secure forms work fine in all browsers except IE 8 that I'm testing on. Loading the secure form, the IE Information bar pops up and states: "To help protect your security, Internet Explorer has blocked this website from displaying content with secuirty ertificate errors. Click here for options."

    Looking at the CAPTCHA, it is the culprit as it just continues to shows that it's loading.

    Even if I click on the bar and tell IE to Display Blocked Content, it reloads and the bar appears again, with the CAPTCHA still not appearing.

    Any help on this?

  • Profile Image
    NeilVicente
    Answered on November 16, 2012 at 03:41 PM

    Actually, the captcha image is hosted on a secure link. It is the GoDaddy verification image that is being blocked by IE.

    Kindly change the link to a secure one to avoid security issues with IE.

     

    Let us know what happens afterwards. Thanks!

  • Profile Image
    guest_23205663983054
    Answered on November 20, 2012 at 02:18 PM

    Nope. Still having problems. I deleted the GoDaddy image, but I keep getting the sercurity certificate error on the IE information bar. https://secure.jotform.us/form/22954517492158

    The CAPTCHA is what keeps loading. I deleted the CAPTCHA element and it finally went through on IE, I"m still thinking the CAPTCHA is the culprit here.

  • Profile Image
    NeilVicente
    Answered on November 20, 2012 at 02:25 PM

    Sorry, but I beg to disagree. I am of the belief that the culprit is the GoDaddy image and not the captcha field.

    The captcha image is using https whilst the GoDaddy image was using http.

    Now that you have deleted the GoDaddy verification image, the security warning no longer appers. The form loads perfectly on IE.

  • Profile Image
    guest_23205663983054
    Answered on November 20, 2012 at 02:41 PM

    Not for me. Still having trouble on my end. I deleted the GoDaddy image and included your GlobalSign SSL seal. I've checked every image on the form and every image is showing https. Why would the CAPTCHA just show the loading symbol?  Using IE 8.0

    Also, when you check the image source on the jotform edit form screen..yes they might be http://, but if you are using a secure form and check the image source from the web browser...they are on https:// either way

    Screen-shot

  • Profile Image
    guest_23205663983054
    Answered on November 20, 2012 at 02:52 PM

    I'd rather use your CAPTCHA since it's a little easier....but it seems like the reCaptcha works without error if I need to go to that....

  • Profile Image
    NeilVicente
    Answered on November 20, 2012 at 02:58 PM

    Hello,

    Sorry for the delayed response. If the recaptcha works for you, then feel free to use it.

    Meanwhile, I'll be conducting further investigation with regard to your original issue.