My conditional logic is not working

  • Profile Image
    Victiara
    Asked on July 05, 2018 at 11:57 PM

    I have tried changing the order of the conditions, cloning the form, and various other things, but nothing seems to fix it. 


    The problem keeps changing everytime I go into it.

    The conditions I have made around "Contact "Method and Purpose" are not working. 

    When I select "relationship call, big accounts" it is skipping to the Distributor Audit page, instead of the page 3, which is the next page. If I delete these conditions it still skips. 

    Sometimes I go in and it's working but instead the Customer Visit conditions are not working and skipping to either Distributor Audit or the Not selling diagnosis. This is very frustrating and I cannot seem to work out why.



  • Profile Image
    BJoanna
    Answered on July 06, 2018 at 02:25 AM

    I tested your form and all Skip to/ Hide a page conditions are working properly. I think that the issue on your end is related the Auto Fill feature that is enabled in your form and Clear Hidden Filed Values settings. 

    Please set Clear Hidden Filed Values to Clear On Being Hidden and test your form again. 

    1530858216clear.JPG

  • Profile Image
    Victiara
    Answered on July 06, 2018 at 02:49 AM

    Thanks BJoanna! This seems to have worked :-)

  • Profile Image
    BJoanna
    Answered on July 06, 2018 at 03:45 AM

    You're welcome.

    Feel free to contact us if you have any other issues or questions.