Card Form: Load time of a form with uploaded images (background, logo, product) is very slow

  • Profile Image
    Patti Pacifico
    Asked on August 02, 2018 at 10:50 PM

    I have published my Catalog Order Form. I have the bag but do not get a checkout button. I have configured the PayPal integration as directed, I believe. 

    I tried to run through and Next is not working on the Welcome Page, it interminttently fails at the Address card and I submit and it says Only ONe Entry Allowed. I don't remember setting that up anywhere. 


    Please advise. 


    Thank you so much.


    Patti 

  • Profile Image
    BJoanna
    Answered on August 03, 2018 at 04:08 AM

    I successfully submitted your form and I was redirected to the PayPal checkout page. 

    1533282656paypal.JPG

    You cannot make submit your form again because you enabled the Unique Submission feature. This feature is used to prevent duplicate submissions. 

    How to Set Unique Submissions on a Form

    Regarding your issue with the next button - Was the form fully loaded when the next button was not working properly. 

    When I tested your form I noticed that the load time of the form is more than 1 minute. This issue seems to be related to the images you uploaded to the form (background, logo and product images). I will report this issue to our developers and we will inform you via this thread once this issue is resolved. 

  • Profile Image
    pattpac
    Answered on August 03, 2018 at 05:35 AM

    I fixed the unique response. Yes please let me know about load time.

    I did get redirected to PayPal but I am still not seeing the checkout logo. Neither in the form or like your picture.

    I am also not recieving the autoresponder email.

    DOes the order have to submit through Paypal  beforeI get any email?

    Thanks, Patti

  • Profile Image
    BJoanna
    Answered on August 03, 2018 at 10:35 AM

    We will inform you via this thread once the issue with the load time is resolved. 

    I tested your form again and the checkout logo was shown. Is your email address shown on your end instead of the logo? I am not 100% sure but I think the system can detect that that is your email address and because of that it is showing the email address and not the logo. Your users will see the logo. You can also test this from some other device. 

    As for your latest question - the Email Notification and Autoresponder email will be triggered by default only when the payment is made. If you want that emails are triggered for the incomplete payments as well, then please check this guide:

    How to Setup Incomplete Payment Notification Email


  • Profile Image
    BJoanna
    Answered on August 06, 2018 at 10:29 AM

    The issue with the load time should be fixed now. 

    Please test your form and let us know if the issue still persists on your end. 

  • Profile Image
    BJoanna
    Answered on August 07, 2018 at 01:15 PM

    It seems that the load issue is no longer related to the images you uploaded to the form, so I will move that issue and your other question to separate threads to avoid confusion. 

    https://www.jotform.com/answers/1546934 

    https://www.jotform.com/answers/1546935 

    https://www.jotform.com/answers/1546936 

    https://www.jotform.com/answers/1546937