Conditions on my form is not working

  • Profile Image
    FrancescaBernardini
    Asked on August 19, 2018 at 04:17 AM

    Suddenly, the form isn't following some conditional logics (which are exact and were working properly before) anymore: What can I do?

  • Profile Image
    Kiran
    Answered on August 19, 2018 at 07:55 AM

    I have checked your Jotform and see that there are 30 conditions set on the form. Could you provide us with more information on which condition is not working on the form so that we can assist you further? 

    We will wait for your response. Thank you! 

  • Profile Image
    FrancescaBernardini
    Answered on August 19, 2018 at 09:58 AM

    The problem starts from question 37 which is about the robbery and the form doesn't respect the conditional logic of questions: 40 and 41. Meanwhile there is the same problem with the question 45 because the form doesn't respect the same conditional logic so questions 46-47-48 appear in any case.

  • Profile Image
    Victoria_K
    Answered on August 19, 2018 at 10:31 AM

    Hello,

    My apologies, but I can not provide a proper suggestion, because we do not have an information on which exact cases fields should appear. I was checking the logic under your form and have noticed several conflicts to fix. Please note that if you've added a statement to show a field, this field will be hidden until the condition is met. I can see that, for example, field #41 is controlled by 2 statements (#1 and #23). It is not shown correctly, because if condition 1 is not met, the field should be always hidden, what creates a conflict with condition 23, which states to show it.

    Please check the conditions again having in mind said above. We are always glad to assist if you need more help.

  • Profile Image
    FrancescaBernardini
    Answered on August 19, 2018 at 11:08 AM

    1534690871Screenshot_20180819-165643.jpgthe question 1 doesn't have the conditional logic. In general the conditions are right and they worked well but since yesterday in the evening they started to work bad. The problem isn't that the form hides me the questions but that actually it shows me the question instead of hide them. I need to solve this problem as soon as possible. 1534690898Screenshot_20180819-165706.jpg1534690929Screenshot_20180819-165709.jpg1534690958Screenshot_20180819-165838.jpg


  • Profile Image
    Mike
    Answered on August 19, 2018 at 11:52 AM

    The Show rules should not be applied to the same field multiple times.

    To illustrate this, you are showing the fields 46, 47, 48 with the next condition:

    At the same time, you are showing them with the next conditions:

    I assume that the second screenshot is showing the correct conditions. In this case, the corresponding fields (46, 47, 48) should be removed from the first condition:

    The same is true for other fields. Please check this from your end.

  • Profile Image
    FrancescaBernardini
    Answered on August 20, 2018 at 12:16 PM

    Problem solved, thank you very much