Adding parameters in Lightbox and Feedback forms

  • Profile Image
    onceproject
    Asked on December 21, 2012 at 04:34 PM

    Here is the website where I'm using the form: http://ocbestcardeals.com ( first form at bottom under special offers )

    Here is the code I'm using for the form:

    --------------------------------------------------

    <script src="http://max.jotfor.ms/min/g=feedback2" type="text/javascript">
    new JotformFeedback({
    formId:'xxxxxxxxxxxxxxx',
    base:'http://jotform.co/',
    windowTitle:'Request Info',
    background:'#FFA500',
    fontColor:'#FFFFFF',
    iframeParameters: {
    'q12_car': 'toyota'
    },
    type:false,
    height:500,
    width:700
    });
    </script>

    --------------------------------------------------

    this is the source code from the browser:

    -----------------------------

    <input type="hidden" class="form-hidden" value="" id="input_12" name="q12_car" />

    ------------------------------

    When I submit the form, and see the response on my email, I can't see the car field or answer.

     

    Is there something I'm doing wrong?

  • Profile Image
    jonathan
    Answered on December 21, 2012 at 05:31 PM

    Please try changing the iframeParameters field name to car instead. Like this..

     

    <script src="//max.jotfor.ms/min/g=feedback2" type="text/javascript">

    new JotformFeedback({

    formId:'xxxxxxxxxxxxxxx',

    base:'http://jotform.co/',

    windowTitle:'Request Info',

    background:'#FFA500',

    fontColor:'#FFFFFF',

    iframeParameters: {

    'car': 'toyota'

    },

    type:false,

    height:500,

    width:700

    });

    </script>

     

    I believe this is specifically mentioned on this guide Adding-parameters-in-Lightbox-and-Feedback-forms

    Please try this and inform us if it still does not work.

    Thanks.

  • Profile Image
    onceproject
    Answered on December 21, 2012 at 05:43 PM

    Hi, I did that and it still doesn't work. Do you have any more suggestions?

  • Profile Image
    jonathan
    Answered on December 21, 2012 at 06:16 PM

    How about changing the src to feedback from feedback2

    ------

    <script src="//max.jotfor.ms/min/g=feedback" type="text/javascript">

     

    new JotformFeedback({

     

    formId:'xxxxxxxxxxxxxxx',

     

    base:'http://jotform.co/',

     

    windowTitle:'Request Info',

     

    background:'#FFA500',

     

    fontColor:'#FFFFFF',

     

    iframeParameters: {

     

    'car': 'toyota'

     

    },

     

    type:false,

     

    height:500,

     

    width:700

     

    });

     

    </script>

     

    Please try also. Continue updating us if not yet fixed.

    Thanks.

  • Profile Image
    onceproject
    Answered on December 21, 2012 at 06:23 PM

    Thankyou very much, that worked.

  • Profile Image
    jonathan
    Answered on December 21, 2012 at 06:26 PM

    Glad to know it does now. I can confirm that it now works as intended.

    Thanks.

  • Profile Image
    guest_30073593991056
    Answered on January 08, 2013 at 12:27 PM

    Hi Jonathan,
    the js source feedback2 doesn't work with "iframeParameters" ?

    Why I found feedback2 in the lightbox script?

    In my test only "feedback" source work fine.

    Thanks

  • Profile Image
    idarktech
    Answered on January 08, 2013 at 12:39 PM

    @guest_30073593991056

    the js source feedback2 doesn't work with "iframeParameters" ?

    That's correct. Probably because feedback2 source uses jQuery.

    Why I found feedback2 in the lightbox script?

    That uses jQuery and should help fixed any script conflict issues when the lightbox script is embedded to a webpage. So, we still recommend using feedback2. If you'd like to use the lightbox parameter features, you can always switched to feedback. It's actually fine.

    In my test only "feedback" source work fine.

    You are correct. Lightbox parameters only works on feedback (prototype script)

    Let us know if you have further questions. Thanks!