Facebook integration error

  • Profile Image
    bhhscu
    Asked on January 02, 2013 at 08:47 PM

    When a user tries to log into Facebook to submit the form, the following error screen appears.

    How can I fix this?

  • Profile Image
    jonathan
    Answered on January 02, 2013 at 10:18 PM

    Hi,

    It is possible that you have not applied the correct APP ID. You have to have an app id created for the integration to work.

     

    When initially doing the integration, it will ask for the app id, there is also a help button -- try to use that.

    Please inform us if you are still not able to make it work.

    Thanks.

  • Profile Image
    bhhscu
    Answered on January 02, 2013 at 10:25 PM

    Hi,

    Thanks for your reply.

    I have checked that I have entered the correct App ID. The Facebook button works in the preview, but when trying it anywhere else, including the "Open in a new tab", it shows the error as attached above.

  • Profile Image
    jonathan
    Answered on January 02, 2013 at 10:34 PM

    Please try test this form. http://www.jotformpro.com/form/30017868992969

    I use your form, and I integrated my personal facebook account on it. I was able to make it work just fine.

    Please inform me if this form does not allow you to login using your facebook account using the submit button.

    Thanks.

  • Profile Image
    bhhscu
    Answered on January 02, 2013 at 11:26 PM

    Hi,

    Your application seems to allow me to log into Facebook and give the app permissions, however there is no submit button.

    I will try making another Facebook application and get back to you.

    Thank you.

  • Profile Image
    bhhscu
    Answered on January 02, 2013 at 11:30 PM

    Hi,

    I just created another app using the procedures outlined in the Integrations wizard, however it gives me the same error apart from in the Preview.

    I believe there may be some settings on Facebook that may cause this error, is there anything I must change on Facebook?

  • Profile Image
    bhhscu
    Answered on January 02, 2013 at 11:39 PM

    I have noticed that when I click the Facebook button on the preview, it comes up with this page, with the correct app ID.

    http://www.facebook.com/dialog/plugin.perms?display=popup&app_id=282971268491969..... etc

    However, when I click the Facebook button on another page, it comes up with this:

    http://www.facebook.com/dialog/plugin.perms?display=popup&app_id=477744215604796..... etc

  • Profile Image
    bhhscu
    Answered on January 03, 2013 at 12:01 AM

    Hi,

    It seemed that it was the form causing the error.

    I duplicated the form and tried it again and it works perfectly.

    Thank you very much for your help.