What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Intergration into Salesforce is not working

    Asked by pivotmedia on January 07, 2013 at 03:53 PM

    I've been trying to intergrate using sales force and i've had this loading image going for the past 30 minutes and nothing has happened. does it normally take this long?

     

    i entered all the required fields and select lead and clicked next, but it gets stuck there.

    Page URL:
    http://www.jotform.com/?formID=22845079114959

    sales force salesforce integrati salesforce form
  • Profile Image

    Answered by jeanettebmz on January 07, 2013 at 04:20 PM

    Can you please tell us if you have followed this guide?

    Please have in mind you need to get the Security Token and your credentials correctly setup into the integration

  • Profile Image

    Answered by pivotmedia on January 07, 2013 at 05:29 PM

    yes, I was provided with all the necessary information needed and it was entered.  Once I got to the next section to select contacts or leads, I selected leads and clicked next.  This is where it just stayed.

  • Profile Image
    JotForm Support

    Answered by Mike_T on January 07, 2013 at 06:05 PM

    Thank you for provided information.

    We have created a bug report ticket, and escalated it to our Development Team. We will keep you updated via this thread.

    In the meantime, you may try the integration in any other browser (Google Chrome for example) to see if that makes any difference.

  • Profile Image

    Answered by pivotmedia on January 08, 2013 at 02:19 PM

    I have verfied that the fields were incorrect on my end, within Jotform.  I updated, also tried Chrome and nothing.

    I'm not sure if I should also have the hidden fields, provided my client, within jotform.

    Below is what I was provided by client.

    Visible Fields

    =========

    First Name  

    Last Name 
    Email  

    Phone
    Job Title  

    Company
    Industry  

    Country

    State
    # of Network Users 

    Network Bandwidth (Gbps)

    Comments


    Hidden Fields

    =========
    Lead Source  = "Advertisement"

    Lead Source Details = "13Q1 - Telecompetitor - Banner Ads"
    Campaign = "701400000007hv5"

    Campaign Member Status = "Responded"
    Lead Status = "Open"

    Lead Rating = "Warm"

     

    Thanks

  • Profile Image
    JotForm Support

    Answered by idarktech on January 08, 2013 at 03:18 PM

    @pivotmedia

    I have verfied that the fields were incorrect on my end, within Jotform.  I updated, also tried Chrome and nothing.

    This has been forwarded to our dev team. Once an update is released, we'll let you know.

    I'm not sure if I should also have the hidden fields, provided my client, within jotform.

    We would appreciate if you could post this question to a separate thread since it is not related to this issue? This thread is already forwarded to our dev team, it is confusing if we create another branch for this topic. Thanks for your cooperation!

  • Profile Image

    Answered by pivotmedia on January 10, 2013 at 10:26 AM

    Any updates?

  • Profile Image
    JotForm Support

    Answered by Deygus on January 10, 2013 at 10:39 AM

    We do apologize and thank you for any patience you give us but unfortunately we do not have any updates just yet. We will let you know as soon as we can here.

  • Profile Image

    Answered by pivotmedia on January 14, 2013 at 02:55 PM

    It's working now, but the client isn't seeing the data within in his salesforce.

  • Profile Image
    JotForm Support

    Answered by Deygus on January 14, 2013 at 03:05 PM

    Thank you for this information from your end of things. Did this happen with a new integration on your side or were you checking it for changes? You may want to try adding the integration again with a clone of your form to see if a rebuild of the integration helps.

    I will also check with our developers on this to see what's going on with this and we will get back to you as soon as possible.

  • Profile Image

    Answered by pivotmedia on January 14, 2013 at 03:11 PM

    I just went back in and added to integrate and it worked. Still a glitch on clients side within salesforce. Thanks

  • Profile Image
    JotForm Support

    Answered by Deygus on January 14, 2013 at 03:19 PM

    Okay so then it's just the data that's not going through now, thank you for letting us know about this.

  • Profile Image

    Answered by pivotmedia on January 14, 2013 at 03:21 PM

    That's correct.

  • Profile Image

    Answered by pivotmedia on January 15, 2013 at 03:06 PM

    Everything set up properly; however the client is not seeing data within salesforce.

  • Profile Image
    JotForm Support

    Answered by Mike_T on January 15, 2013 at 03:10 PM

    Our Developers are looking into this. Thank you for your patience in this matter.

  • Profile Image

    Answered by cettox on May 06, 2013 at 07:36 AM

    As I investigated the issue, it seems to be working now. I am closing the ticket now, if you ever have problems with salesforce integration please let us now!

     

    thanks.