Contact form will not submit

  • Profile Image
    guest_30113026096038
    Asked on January 12, 2013 at 10:05 AM

    I have made a simple contact form. Looks good and works well from your website.

    When I submit the code in my website the form appears, you can fill it in, but when I want to submit it the warning

    "Form ID did not match" so the message is not send.

     

    Question: what do I wrong?

     

    Regards,

     

    Peter Hanselman

  • Profile Image
    pinoytech
    Answered on January 12, 2013 at 10:19 AM

    Hi Peter,

    Sorry for the inconvenience that may have caused. Can you please provide us your website URL where your form embedded to investigate the said issue?

    Thank you!

  • Profile Image
    guest_30115172195042
    Answered on January 12, 2013 at 01:03 PM
    URL is not yet available. I am developing a concept website, using iWeb. Testing the site on my Mac causes the warning: Form id did not match
  • Profile Image
    moonzkie
    Answered on January 12, 2013 at 01:40 PM

    Hi,

    Can you please specify the codes that you have used to embed your form?

    Thank you.

  • Profile Image
    pinoytech
    Answered on January 12, 2013 at 02:41 PM

    @guest_30115172195042,

    For some reason, your response came out empty. Can you please response via this link: http://jotform.me/answers/165122-Contact-form-will-not-submit#2

    Thank you!

  • Profile Image
    Peter
    Answered on January 12, 2013 at 02:47 PM

    <script type="text/javascript" src="//form.jotformeu.com/jsform/30113004941336"></script>

  • Profile Image
    pinoytech
    Answered on January 12, 2013 at 02:57 PM

    Have you tried already embedding your form code using iFrame method? If not, can you please give a try?

    Thank you!

  • Profile Image
    Hanselman
    Answered on January 12, 2013 at 04:50 PM

    I just did. Works fine on your website. Helas not in mime. Same result: ERROR Form ID did not match.

  • Profile Image
    Welvin
    Answered on January 12, 2013 at 05:09 PM

    @Hanselman,

    I just did a test message and it went through without error;

    Please clear your browsers cache before trying again. Thanks

  • Profile Image
    guest_30115886930051
    Answered on January 13, 2013 at 03:08 AM

    Hi, when I run the contact form on your website it works excellent, same result as you. Problem is when I try to test it on my concept iWebsite on my Mac the error message 'Form id will not match' appears.

    After uploading my website I will test it from the internet.

    Thx for your help.