Get Visitor Location widget - not working?

  • Profile Image
    totswindow
    Asked on January 14, 2019 at 11:28 PM

    why there no data showed by Get Visitor Location widget?

    is it working or not???

    please advise..


    thanks..

    1547526488get visitor location.JPG

    1547526321get visitor location2.JPG1547526374get visitor location3.JPG

    Screenshot
  • Profile Image
    totswindow
    Answered on January 15, 2019 at 01:14 AM

    is there any alternative for this?


    thank you..

  • Profile Image
    Nik_C
    Answered on January 15, 2019 at 05:27 AM

    We're sorry for the inconvenience.

    I tested the Get visitor location widget, but I wasn't able to replicate any issue.

    Could you please try testing your form with another Browser (or from the incognito mode in Chrome).

    Let us know if you're still able to replicate this problem.

    Thank you!

  • Profile Image
    totswindow
    Answered on January 15, 2019 at 06:23 AM

    still not showing..

    1547551191get visitor location4.JPG

    1547551247get visitor location5.JPG

    the IP there is the "email {ip}"

    not from GET VISITOR LOCATION WIDGET..

    it must show the IP and Location isnt it????

  • Profile Image
    Kiran
    Answered on January 15, 2019 at 10:01 AM

    Yes. They should. I have checked your Jotform and see that the Get Visitor location widget fields are hidden on the form. This is causing the data not to be sent to your submissions. If you do not want to display the data being captured by the widget on the form, you may consider using the option 'Show Details' in the widget wizard. 

    154756443615012019_200149_33.png

    Please unhide the widget fields on the form so that they should be capturing the data to your submissions without any issue.

    Hope this information helps! 

  • Profile Image
    totswindow
    Answered on January 15, 2019 at 11:35 AM

    it is not working..i create another form for it..

    1547570024get visitor location6.JPG

    1547570063get visitor location7.JPG

    1547570086get visitor location8.JPG

    it is all show now..any difference??

  • Profile Image
    BJoanna
    Answered on January 15, 2019 at 01:03 PM

    I tested your forms and only the Tots Window Shipping Fee Round Up recorded the IP address and Location. 

    Your Tots Window Order Form form is not recording the IP address and Location because the widgets are hidden inside of the field settings. To resolve the issue, you need to set Hide Filed option to OFF, inside of the field settings.

    15475749922.PNG

    You can hide the widgets inside of the widget settings. 

     15475750251.PNG

    Here is my form - https://form.jotform.com/90144622543956 

    Please clone it and then test your cloned form to see if the widget is working properly. 

  • Profile Image
    totswindow
    Answered on January 15, 2019 at 09:39 PM

    here is what you advise..

    1547605757get 1.JPG1547605793get 2.JPG

    1547605835get 3.JPG

    1547605913get 4.JPG

    1547605940get 5.JPG

    1547605957get 6.JPG

    1547605974get 7.JPG

    I put blue mark on..i follow your guide

    but still the data i need to get is not working..

    hopefully the picture above is your reference..

    is there something i done wrong??? your testing have a red mark that show IP..

    it is a big question mark to me..


    thanks in advance..




  • Profile Image
    Kiran
    Answered on January 15, 2019 at 11:00 PM

    I have tried sending a test submission to the form and see that the IP address and the location is displaying normally on the form and in the submission.

    154761091716012019_090154_41.png

    I have also checked the email notification that was sent and see that the widget data is displayed properly.

    154761089916012019_090129_42.png

    Were you able to fix the issue at your end? If you are still experiencing any issue with the form, please check if the browser is allowed to read the location data.

    154761118916012019_090157_43.png

    You may also try using a different browser or a different device and see how it works.

    Thanks!

  • Profile Image
    totswindow
    Answered on January 16, 2019 at 08:52 AM

    it seem i cant make it work on my testing..

    any alternative that can advise?


    thanks..

  • Profile Image
    Kiran
    Answered on January 16, 2019 at 10:46 AM

    It looks like you have removed the widgets from your form https://www.jotform.me/form/83488445674472. You may try adding the widgets again to the form or check the other form on a separate device or a mobile device. Please make sure that the Jotform is provided with the appropriate rights to access the location.

    Thanks!