There is a problem with underscores in email addresses

  • Profile Image
    AndyBell
    Asked on January 20, 2019 at 05:20 PM

    When I use an underscore in an email address it prevents the form being submitted on an iPhone. There is no reason given why it refuses to submit and if you change the address it still doesn't submit. However, if you complete the form again with another email address with no underscore then it works fine.

    The underscore also messes up the formatting of the submitted email if you use the underscore address and submit via a desktop browser.

  • Profile Image
    BDAVID
    Answered on January 20, 2019 at 06:28 PM

    I have cloned your form, and it worked fine submitting with an email address that has an underscore. I tried it in desktop, and in an iPhone emulator:

    1548026841worked.png

    I have cleared your forms cache, please try again. If the issue persists, can we try submitting your form?

    Also, try submitting my clone version, and let us know if the issue happens on it too: https://form.jotform.com/90196979995989 

  • Profile Image
    AndyBell
    Answered on January 21, 2019 at 02:43 AM
    I have tried both your form & mine this morning & it works fine. I’ll get the other person who tried & failed to get it to work later this evening.
    Cheers
    Andy
    Sent from my iPhone
    ...