1 drop down menu isn't showing on form when embedded on website

  • Profile Image
    iaom
    Asked on January 30, 2013 at 10:41 AM

    Hello.

    We've recently put together a registration form. The drop down menu (number of banquet tickets) isn't showing on the form when the code has been embedded into our website. All of the other parts of the form are displaying correctly. Could you please advise what might be wrong. 

    The form is the IAOM Annual Conference & Expo Registration Form. 

    Thank you! 

    Melinda 

  • Profile Image
    abajan
    Answered on January 30, 2013 at 11:34 AM

    Hi Melinda,

    Unfortunately, whenever I click the link to examine the page, I get a message that I don't have permission to preview drafts but I take it from what you've stated that the form works okay at its own address but not when it's embedded in the web page?

    Looking forward to your reply.


    Wayne

  • Profile Image
    iaom
    Answered on January 30, 2013 at 11:48 AM

    TRY THIS URL TO VIEW THE PROBLEM: http://www.iaom.info/annualmeeting/online-registration/

  • Profile Image
    abajan
    Answered on January 30, 2013 at 11:58 AM

    Thanks for the new link. There may be conflicts between the form's code and your page's scripts. Try using the iFrame version of the form and let us know if that helps:

  • Profile Image
    iaom
    Answered on January 30, 2013 at 12:10 PM

    Hi Wayne,

    Thanks for the suggestion. Unforuntately, that didn't work. Any other ideas? The first dropdown menu (Please indicate which day) I used appears without a problem.  

    -Melinda

  • Profile Image
    abajan
    Answered on January 30, 2013 at 12:27 PM

    Hi again Melinda,

    There was an issue where updates are being applied to the non-secure version of your form but not to the secure one, but I believe I've fixed the problem. Please confirm that the form is showing the missing field now.

    Thanks.


    Wayne

  • Profile Image
    iaom
    Answered on January 30, 2013 at 12:34 PM

    Hi Wayne,

    It appears to be working now. Should I expect a similar problem in the future or should the fix take care of this going forward? 

    Does it matter which embed code I use? iFrame or Embed?

    -Melinda

  • Profile Image
    abajan
    Answered on January 30, 2013 at 01:10 PM

    Hi again,

    To answer you last question first, it wouldn't matter which of the two codes is used. It's just that I initially mistakenly thought the issue was due to conflicting scripts.

    I'm pretty sure the fix should take care of the problem going forward but I couldn't guarantee that 100%. The best I can state is that I can't recall the problem reoccurring once it has been fixed. (What I did was go into your account, load the form and click its Save button.) If it does happen again, try clicking the Save button.