DocuSign widget: Periodic break in connection between Form and Docusign

  • Profile Image
    schlonsp
    Asked on February 06, 2019 at 09:28 PM

    This has happened more than once. New member signup...person fills in everything on the lengthy form and when they hit the Docusign widget to sign the form it gives them an error (see attached screenshot).  Frustrating to our prospective new members.  We need a reliable means to collect signups and the Docusign piece must work. The fix is for me to go into the form and re-authenticate the Docusign widget account to get it working again.  I shouldn't have to do that.  The Docusign account didn't change and it has plenty of paid envelopes to draw from.  Can you explain why this happens and let me know what I can do to make sure it doesn't happen again?

    Screenshot
  • Profile Image
    Richie_P
    Answered on February 07, 2019 at 12:30 AM

    We are sorry for the inconvenience this may have caused.

    May we know if your form is embedded to a web page?

    I have tested my sample Form and I can't seem to replicate the issue with the DocuSign Widget.

    However, checking from your screenshot it seems that the widget was not working correctly.

    May we know if the issue still remains after re-authenticating your Docusign?

    Looking forward in your response.


  • Profile Image
    Steve schlonski 
    Answered on February 07, 2019 at 10:15 AM

    The form is not embedded in a webpage. Yes, I know how to fix the problem by reauthenticating, but the point is i shouldn't have to.  What caused it to stop working in the first place?  Trying to recreate the problem like you're doing is worthless unless you plan to check back on you're test form a month later to find out it isn't working.  This problem never occurs right away.  The last time it happened was 4 weeks ago.  It worked fine for 4 weeks accepting about 6 new member apps and then decided to break for no apparent reason. I need to know why before seeking an alternate form solution. 

  • Profile Image
    Richie_P
    Answered on February 07, 2019 at 11:36 AM

    We do sincerely apologize about any inconveniences that this may have caused you.

    I do understand the frustration this problem has created for you.However, in order for us to know the reason why the widget has stopped working we  need at least a console report of the issue so that we can forward it to our developers for further checking.

    Guide:https://www.jotform.com/help/453-How-to-get-a-console-report-from-most-common-browsers

    Hope this information helps.



  • Profile Image
    schlonsp
    Answered on February 07, 2019 at 11:30 PM

    Sorry I can't give you a console report.  After I re-authenticated the widget, the error no longer happens.  When (or if) it happens again, I'll be sure send you a console report to troubleshoot.

    Steve

  • Profile Image
    schlonsp
    Answered on March 08, 2019 at 11:30 PM

    Well, it was only a matter of time before it happened again.  Here's the console report.  It's very disconcerting to get a call from a customer to let me know this widget integration has failed again.  This is the third time.  It seems to stay working form 3-4 weeks before the widget breaks and I have to resync it.  Our business can't afford to have this happen every month.  Please fix.

     1552105360Console Report.PNG


    Here's another screenshot of the error message (same as before):

    1552105777Docusign Signing Error2.png

  • Profile Image
    Victoria_K
    Answered on March 09, 2019 at 06:38 AM

    I was searching for possible options to help you and found the following information. Please check if Password Rules are set for the account. Password can be expired causing the integration to disconnect. It is under Settings, https://admin.docusign.com/security-settings

    Also, if two-step verification is enabled recently for your account, that may have caused it too. Once enabled, all connected apps needs to be reconnected/reauthenticated for it to work.

    If you did not set Password Rules and no 2-step but still getting the issue, let us know here, and we'll create a ticket for you. 

  • Profile Image
    schlonsp
    Answered on March 09, 2019 at 11:21 PM

    I checked my Docusign Account. There are NO password rules set and two-step verification is NOT turned on (and never has been).   Please create a ticket as you proposed.  I need to get this resolved before it happens again. 

  • Profile Image
    Victoria_K
    Answered on March 10, 2019 at 04:56 AM

    I am creating a ticket for your query so our developers could check for other possible reasons for the widget to disconnect. I have also cleared form caches for your account, this could help as well. 

    Unfortunately, we can not promise a time frame for a response, but they will get back to you as soon as possible. 

  • Profile Image
    NeilVicente
    Answered on October 23, 2019 at 09:03 AM

    Hi there,

    First off, we are sorry for the late update.

    We have figured out the cause of this problem and have rectified it. 

    However, you must re-authenticate your widget to grant our app an extended scope, so we can indefinitely renew your widget's access token.

    Open the widget set up sidebar, click the Re-authenticate button, and then grant Jotform the permission as illustrated below:

    1571835582DocuSign_extended.png

    Please do let us know if you have any other questions or concerns of if you need any help in regard to this issue.

    Best,