Inventory widget: displaying 'We cannot complete your request' error message

  • Profile Image
    auburnmapto
    Asked on March 25, 2019 at 01:03 PM

    Hi,

    I am having two issues with my form.  First, I am trying to use the Inventory widget and it is putting up a message on each item that says "We cannot complete your request" and I am not sure why.  See screenshot below for example.

     

    A

    lso, I am trying to tie the Inventory Management to Paypal somehow.  I am basically trying to say when there are no more tickets to be sold by that school that there is no longer an option to buy them through PayPal by taking away the option to purchase (either gray out or another method).  Is this possible?

    Is there a better way to display the payment options through the Paypal Widget?  I would love to have the user select the school then from a drop-down menu select either Individual, Pair or Team and have the appropriate cost show up for them.  We only want them to select one option as well in the Payment container.

     

    Thanks for your help

  • Profile Image
    Kiran
    Answered on March 25, 2019 at 02:24 PM

    Please try updating the widget on the form so the widget should be working fine.

    155353824025032019_230310.png

    The other question is moved to a separate thread and shall be addressed there shortly. Please follow the link below:

    https://www.jotform.com/answers/1771279

    Thanks!

  • Profile Image
    auburnmapto
    Answered on March 25, 2019 at 05:15 PM

    Hi, 

    I did try to update the widget with no success. I am still seeing the error message as seen in the screenshot.  I did try to delete and add back in but even when I add fresh it still shows error message. Not sure what to do from here. 

    Thanks 

  • Profile Image
    auburnmapto
    Answered on March 25, 2019 at 05:43 PM
    Hi, 
    I tried to update the thread in all 3 options and it is still not working.  Thoughts?
    Thanks,Kristina
    Auburn MA PTOAuburn, MassachusettsProudly serving Auburn Integrated Preschool, Bryn Mawr Elementary, Pakachoag Elementary and Swanson Road Intermediate Schools.
    On Monday, March 25, 2019, 2:24:14 PM EDT, JotForm wrote:

    A new response has been received: Answered by Kiran

    Please try updating the widget on the form so the widget should be working fine.
    The other question is moved to a separate thread and shall be addressed there shortly. Please follow the link below:
    https://www.jotform.com/answers/1771279
    Thanks!
    View this thread on browser » Unsubscribe Thread 1553538254
    ...
  • Profile Image
    jherwin
    Answered on March 25, 2019 at 08:18 PM

    I have checked your JotForm and tried to update the widget which didn't work for me as well. It seems there is an issue with the form or widget itself since I am not able to replicate the issue on the cloned version of the form. The widget on a different form is working fine.

    Let me forward the issue to our backend team to take a look and investigate the issue further. Once we have any information in this regard, you'll be posted here.

    Thank you!

  • Profile Image
    jherwin
    Answered on March 25, 2019 at 08:22 PM

    What you can do for now is to add a new inventory widget to your form and hide the ones that are not updating while our developer investigates the issue.

    Please give it a try and let us know how it goes.

  • Profile Image
    auburnmapto
    Answered on March 26, 2019 at 08:42 AM

    Hi,

    Even if I add a new one inventory widget it still doesn't work.

  • Profile Image
    Kiran
    Answered on March 26, 2019 at 10:01 AM

    I see that the form is in a different account guppiesalmon and seems to be having some test forms. Could you confirm if the submissions received to the forms are only test submissions so that we can try deleting the Widgets API key for the account guppiesalmon?

    We will wait for your response. Thank you! 

  • Profile Image
    auburnmapto
    Answered on March 26, 2019 at 10:09 AM

    Hi,


    Yes, those are only test submissions by guppiesalmon.

  • Profile Image
    Welvin
    Answered on March 26, 2019 at 12:05 PM

    I figured out that you are using a collaboration link to edit the form. It seems that the widget can't create an API through a collaboration method, so that is why the widget is showing the error.

    To fix this, you'll have to ask the form owner to log in to their account, add a new widget to trigger API. I already did this, and that worked. 

  • Profile Image
    hayk
    Answered on April 10, 2019 at 06:39 AM

    Hi @auburnmapto,

    I see the problem has been resolved. Can you confirm that?