What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Blank form

    Asked by Martin on February 13, 2013 at 08:21 AM

    Hi! I've created my first form, which has the following fields:

     

    - Full name

    - Address

    - Email

    - Phone Number

    - PayPal payment tool with several products

    - Submit button

     

    Everything looks good in the form editor. When I click Preview, however, none of the fields show up - I just get a blank form with a Submit button. If I navigate directly to the form URL (http://form.jotform.us/form/30428543310141), I see the same thing. I'm trying this in Chrome and Firefox.

     

    Am I missing something obvious?

     

    Thanks,

    Martin

    Page URL:
    http://form.jotform.us/form/30428543310141

  • Profile Image

    Answered by jefreylandicho on February 13, 2013 at 08:51 AM

    I checked your account and you are log under a guest account. I also notice that their no form created in your account. I would suggest creating a FREE BASIC JOTFORM account to avoid this issue.

     

    If you need further assistance, please let us know.

  • Profile Image

    Answered by ynyc on February 13, 2013 at 09:05 AM

    Hi, thanks for your reply. I actually do have a Jotform account, and the form was created under that account, not as a guest. I just wasn't logged into the account when I posted the question. My username is ynyc.

  • Profile Image

    Answered by jefreylandicho on February 13, 2013 at 09:11 AM

    Can you please try to do the following?

    Clone the form and use the clone form instead.

    Clear your browser cache and cookies

  • Profile Image

    Answered by ynyc on February 13, 2013 at 11:44 AM

    Cloning seemed to fix it. Thanks.