What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why am I missing submissions, and why won't the New Submissions flags clear?

    Asked by nrsco on March 18, 2011 at 10:23 PM

    I have had two instances of a form submission not being received (each sent from the same prospect several days apart).  They were sent from a laptop PC with Vista and IE (recent).

    In both instances the thankyou page presentation and the autoresponder email confirmation went Ok. I have tested the form myself from a computer with clear cache and cannot replicate the problem.

    2nd Problem (not sure if it's related): There are uncleared New Submission flags incorrectly showing on the MyForms page. All available New Submissions have been viewed, yet the flags remain.

    Hope you can help - Thanks!

    Nathan

    Page URL:
    http://www.barnfire.com.au/apply_online.htm

    Screenshot
  • Profile Image
    JotForm Support

    Answered by NeilVicente on March 19, 2011 at 12:20 AM

    Have you checked your junk mail folder? There have been problems in the past with junk mail filters identifying emails coming from our server as Junk Mail.

    You can also try changing the Recipient Email and see if the problem still occurs so we can isolate the reason as to why you're not receiving submissions.

  • Profile Image

    Answered by nrsco on March 19, 2011 at 02:47 AM

    Thanks Neil. I checked the recipient settings and tested it again, it's all Ok from my side. So far this has only arisen with one client, he gets the thankyou age & autorespondr email, but nothing emailed to me, and nothing shown up on Jotform server. Problem is, without knowing a possible cause, I don't know what submissions I could be missing. Could it be a browser issue on the client's computer?

    The uncleared "new" flags are also somewhat disconcerting, does this mean the server data has been corrupted?

  • Profile Image

    Answered by allanftd on March 19, 2011 at 03:37 PM

    Hi Nathan,

    Thanks for your update. If possible, please observe any trend or similarities among your clients that exhibit this problem (i.e. same email service provider or ISP, same location, same time of day, etc). From there, we can further isolate the most probable cause of this issue. At this point, it may also help that you contact your ISP or email provider regarding this issue so that they can also start investigating on their end.

    For the uncleared new flags, have you tried using other browsers to access the submissions page? Also, please try clearing your browser cache and cookies if you haven't done so yet.

    Our apologies for the inconvenience and we really appreciate your patience and cooperation. 

    JOTFORM SUPPORT