Error in form for subscription when client tries to pay in Paypal

  • Profile Image
    product_london
    Asked on April 29, 2019 at 10:38 AM

    I have a couple of clients in the US who are having an issues when trying to pay via Paypal. They hit submit, go to Paypal but when they try to pay, they get an error message saying;

    Start date should be greater than the current date.

    Any ideas why this is happening?

     
  • Profile Image
    Welvin
    Answered on April 29, 2019 at 12:06 PM

    You do not have a date in the form, so I am not sure if the error is related to that. You have a product item which has a trial, but the error seems to be unrelated to the item. Do you have a screenshot of the error? I think that would help us identify the problem. 

    I've cloned your form and tested it on a Sandbox, and it worked for me. 

  • Profile Image
    product_london
    Answered on April 29, 2019 at 12:16 PM

    Hi Welvin, This has happened with 3 different clients, all based in the US. Here's the screenshot;

    GetAttachmentThumbnail?id=AQMkADgzYjQ4Mj

  • Profile Image
    Richie_P
    Answered on April 29, 2019 at 02:18 PM

    Unfortunately, we cannot view the screenshot you have shared.

    Can you please share to us the screenshot again?

    Kindly follow this guide:How-to-add-screenshots-images-to-questions-to-the-support-forum

    Looking forward for your response.

  • Profile Image
    product_london
    Answered on April 29, 2019 at 03:38 PM

    1556566688Start Date Error.jpg

  • Profile Image
    Richie_P
    Answered on April 29, 2019 at 04:31 PM

    May we know if your form is embedded to a web page?

    May we know if you receive this error when you pay using Credit Card or with PayPal?

    Can you please sync your PayPal timezone with your Jotform account?

    To set your PayPal timezone go to your Account settings>Time zone and update.

    In JotForm, go your account settings,Settings>Timezone and edit.


    Please give it a try and let us know if the issue still persists.

  • Profile Image
    product_london
    Answered on April 30, 2019 at 01:17 PM

    Hi Richie, thanks for this. Changing the timezone on Jotform (Its was defaulted to ESP) seems to have done the trick. One of the clients who had the issue was able to signup ok. I'm waiting on the others.