What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form not responding to css once published

    Asked by podlegoop on February 17, 2013 at 11:23 PM

    I have a form I'm working on. I've update some CSS to style and all appears correct in the editior. Once live however, the button template CSS is overriding the CSS I'm inserting for the button. Open this link using firebug to see what I mean. Please help as I would like my CSS to actually work styling this thing. All I'm trying to do is change the height. 

    http://form.jotform.us/form/23044667056151

    Page URL:
    Notliveyetduetoformnotstylingcorrectly

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 18, 2013 at 03:03 AM

    Hi,

    You are currently using a "button style" available on the button properties, this is the reason why a CSS button style is included on your form. I have now switched your button style to a normal default submit button. This should removed the "button style" CSS, so the submit button should now adhere to the CSS injected to your form.

    Another possible solution is to use !important on your injected CSS codes. This should overwrite the CSS button from JotForm.

    Thanks!

  • Profile Image

    Answered by podlegoop on February 18, 2013 at 11:34 AM

    Okay thanks. Now that it's gone, I've reclassed my styles to address '.form-submit-button' but I'm missing something. it all looks like I want except the button background color is white, not gradient blue like the button style was. I copied everything I thought, but this didn't translate. 

  • Profile Image

    Answered by podlegoop on February 18, 2013 at 11:43 AM

    okay, some clarification. The form appears just fine in firefox, but not in safari. 

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 18, 2013 at 02:34 PM

    @podlegoop

    They appears to be fine on my end. All I can see is a darkgrey button since that was set as a background on your form's submit button. This is what I see on my end.

    Would you mind rechecking your form once again?

    Let us know if there's still missing. Thanks!

  • Profile Image

    Answered by podlegoop on February 18, 2013 at 02:37 PM

    Yeah, I changed it. to grey because the gradient blue wasn't working on safari. 

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 18, 2013 at 02:42 PM

    I see but it should suppose to work. I'd suggest to try it again and let us know how it goes.

    By the way, is the grey button displaying on your end now? Thanks!

  • Profile Image

    Answered by podlegoop on February 18, 2013 at 02:59 PM

    They grey button works just fine. 

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 18, 2013 at 03:47 PM

    That's great then. Cheers!