What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    [Internet Explorer 7 & 8] E-Signature Field not showing when form embedded on site

    Asked by KarBar110 on February 21, 2013 at 10:16 PM

    I was so excited to see the new E-Signature field added, and what an awesome way to do it, letting form users sign with their computer mouse.  Perfect.

    Except....

    When I take the embed code and put it on my website:

    http://kporterphotography.com/wedding-contract  (none of the fields are required so you can just hit "next", "next", and then on the third page to show the wayward signature field you do have to progress through the acceptance check boxes as you make your way down the form to the end.  The Signature field is set to appear once the user has answered the question "Will your address change after the wedding".

    The field headline appears, and a blank area, but not the actual signature area.  At first I had my background set to Transparent, so thinking that might be why, I changed the background to tan, and it still isn't showing.  I tried it in both IE and Chrome, to no avail.

    When I view the form link http://form.jotform.us/form/30517694139156 , the ESignature works with no problems.

    Please advise.

    NOTE - If it matters, I read about the Cloud thingy messing with some things, so this form is actually a Clone of the original so it would migrate it to the new server (or whatever the deal was).  Just wanted to let you know in case that was going to be your first suggestion.

    Thanks for the help!

    Page URL:
    http://kporterphotography.com/wedding-contract

    Screenshot
    ESignature embedded form E-Signature not showing
  • Profile Image

    Answered by pinoytech on February 22, 2013 at 03:50 AM

    Hi Karbar110,

    You form is actually working fine especially E-Signature field using latest version of IE, Chrome and FF. Please take a look at this: http://www.screencast.com/t/PKqYGzSCv

    Feel free to contact us again if you need further assistance.

    Thank you!

  • Profile Image

    Answered by Yvonne on February 22, 2013 at 02:03 PM

    Mine is not showing either:  http://luishesslaw.com/immigration-consultation/

  • Profile Image
    JotForm Support

    Answered by Mike_T on February 22, 2013 at 02:42 PM

    We are sorry for the inconveniences caused.

    Our Developers are working on this. It will be fixed in the nearest time.

    We will keep you updated via this thread. Thank you.

  • Profile Image
    JotForm Support

    Answered by mdikici on February 25, 2013 at 08:04 AM

    Should be working now

  • Profile Image

    Answered by markninnim on March 12, 2013 at 06:02 PM

    Hi, 

    I love the signature function but I am still not having any luck in IE;

    http://www.ifpd.co.uk/step4/

    Any news on when this will be ready?

    Keep up the good work

    Mark

  • Profile Image
    JotForm Support

    Answered by Mike_T on March 12, 2013 at 06:28 PM

    Mark, IE 9 & 10 are showing the esignature field on any embed form. We will try to check why the signature is not working in IE 8 on the js form.

    In the meantime, you can try an iFrame code, it should be fine in IE 8 and other browsers. Thank you.

  • Profile Image

    Answered by markninnim on March 13, 2013 at 07:52 AM

    Hi Mike

    I have applied the iFrame code and you are spot on with 9, not sure about 10 but I still cant get 8 to work.

    Sadly, I work in financial services and my regualator will not let me use it until it works on all browsers. Its just my luck they test all!

    Any thoughts or help appreciated.

    Mark

  • Profile Image
    JotForm Support

    Answered by mdikici on March 13, 2013 at 08:58 AM

    Hi Mark, 

    I tested on  Win-7 IE9 (IE8 standards),  Win-7 IE8, Win-XP IE8  through browser stack and all worked. Your browser may cause the problem (i know it did not help you but can't figure out why)

  • Profile Image
    JotForm Support

    Answered by mdikici on March 14, 2013 at 03:00 PM

    Hi everyone,

    i completely re-wrote e-signature function, bugs mentioned here resolved also it is now better looking (hope you guys like it). It should be working now. Could you please try again?

  • Profile Image

    Answered by bodytonicpilates on September 18, 2013 at 11:32 AM

    Hello - I am having the same problem and the jotform technicians who have seen my post don't seem to be helping.  Can one of the technicians from this thread please take a look?

     http://www.jotform.com/answers/268752-E-Signature-Problems#1

     

    Thanks so much!

  • Profile Image

    Answered by pinoytech on September 18, 2013 at 12:10 PM

    @bodytonicpilates 

    Request you to please post your query on a separate thread for further assistance.

    Thank you!