Problem with form updating

  • Profile Image
    fpill
    Asked on February 28, 2013 at 08:01 AM

    I was working on my form yesterday (2/27/2013) and saved all of my changed.

    Today when I open my form I see all of the changes I made yeaterday, but when I preview my form I see an older version, with none of the changes I made yesterday.

    Here is my preview: (I have not published this form yet)

    http://form.jotform.us/form/30572812109146?

     

    I'm not sure how to show you what is saved in my account.

    If it helps, I've tried this in Chrome, Firefox, and IE.

     

    Thanks

    Frank

    P.S. In my screenshot notice the Matrix of textboxes vs my preview which are individual text boxes

  • Profile Image
    glennlee
    Answered on February 28, 2013 at 08:36 AM

    Please try to clear your browser cache. I will do the same in our end. And see if it works.

    Thanks.

  • Profile Image
    fpill
    Answered on February 28, 2013 at 10:20 AM

    That seemed to work.

    Is this something I'm going to have to do all thie time?

     

    Thanks again for your quick response.

  • Profile Image
    jefreylandicho
    Answered on February 28, 2013 at 10:25 AM

    Forms usually updates automatically and you do not need to do this all the time. In case the form does not update by clearing your browser cache or by re-embedding the form using a different method, you may contact us again and we will be glad to assist you and clear your form cache on our side.

  • Profile Image
    fpill
    Answered on February 28, 2013 at 01:25 PM

    I'm sorry, but I'm having the same problem again.

    I cleared my cache before and the preview matched my most recent work.

     

    I posted the form to my website.

    Parallel Resistance Lab:

    https://sites.google.com/site/hswphysics/ap-labs

     

    http://form.jotform.us/form/30572812109146

     

    The form is what I saved yesterday not the most recent revision. 

    I even closed down Chrome and cleared the cache again...same result yesterday's work.

  • Profile Image
    jonathan
    Answered on February 28, 2013 at 04:59 PM

    @fpill

    Hi,

    You will have to update your form's URL to secure version.

    Like this:

    https://secure.jotform.us/form/30378734214150

    https://secure.jotform.us/form/30378075997166

    https://secure.jotform.us/form/30572812109146

     

    This should fix your form's cache issue and will now always use the updated version of your form.

    Inform us if you have further inquiry.

    Thanks.

  • Profile Image
    fpill
    Answered on March 01, 2013 at 07:41 AM

    Thank you I will try that.

    Could you explain why a secure form will solve my problem?

  • Profile Image
    KadeJM
    Answered on March 01, 2013 at 10:05 AM

    On behalf of my colleagues, you are very welcome. 

    The securing is sometimes a safer version to use when an update problem occurs but the trouble with doing this is that it then begins to use your SSL Submission Usage and I'm not quite sure how beneficial this would be since you are currently on the Starter/Free Plan.

    If you want I think that you can actually try using http://www.jotform.us/form/30572812109146 instead, all that has changed is the front of the original form's url but it appears to show your form's updated version though you may want to doublecheck on your end just to be sure.

    Original Embedded Link:

    http://form.jotform.com/30572812109146

     

    New Non-Secured Link:

    http://www.jotform.us/form/30572812109146

     

    If you view the diffference you'll notice that the url's server domain controller has changed so instead of " form. " it's now " www. ".