Problems with default text (value) in autoresponder and notification email

  • Profile Image
    ertezet
    Asked on March 26, 2011 at 07:42 AM

    Hi, 

     

    I created a form where is a field which has in settings filled out default text. What happend is that the default text does not show in the submission emails (either to out client and also in our email). I need to solve out this issue. At the beginning I created one universal form which I cloned for many times.

    Thanks for your advise

    Radek

  • Profile Image
    liyam
    Answered on March 26, 2011 at 01:15 PM

    Hello,

    You seem to have quite a large number of forms, can you give us the link to this form that you're experiencing some problems with?

    Thanks.

  • Profile Image
    ertezet
    Answered on March 28, 2011 at 07:25 AM

    for example following form: http://www.jotform.com/?formID=10804437816 

  • Profile Image
    NeilVicente
    Answered on March 28, 2011 at 08:06 AM

    Hi,

    I looked into your form and I found out that your notification email setup are using invalid {identifiers} that is why your default values aren't being shown in the email alerts.

     

    I copied your form, deleted the invalid id's and replaced it with correct ones by clicking on the corresponding item in the list to the right.

     

     

    Sent a test submission and within a minute, I received an email without any problems at all. The default values are shown in the email.

     

    Repeat the process I did to all your forms including the one you just posted.

     

    Regards,

    Neil

  • Profile Image
    ertezet
    Answered on March 28, 2011 at 09:15 AM

    That´s excatly what I´ve done in a few forms. Particulary this one I already made the changes you show above but it seems that:

    1/ i create a standard form which I clone -> this mistake comes up

    2/ if I remove wrong id´s and replace those correct ones, the mistake might happen again

    3/ for instant the following form has as you write wrong id´s: http://www.jotform.com/?formID=10670637873

     

    NOVÁ REZERVACE: {ubytovaciZarizeni}

    Jméno a příjmení {jmenoA11}
    Ulice {ulice}
    Město {mesto14}
    E-mail {email8}
    Telefon {telefon16}
    Ubytovací zařízení: {ubytovaciZarizeni}
    Datum příjezdu: {datumPrijezdu}
    Datum odjezdu: {datumOdjezdu}
    Počet osob {telefon}

    Poznámky: {Additional_Comments_}

    but the submission we receive is in order:

    NOVÁ REZERVACE: Hotel Ostrov ****

    Jméno a příjmení TEST
    Ulice test
    Město test
    E-mail nemecek@region-tour.cz
    Telefon 123456789
    Ubytovací zařízení: Hotel Ostrov ****
    Datum příjezdu: 16/8
    Datum odjezdu: 18/8
    Počet osob 2

    Poznámky: 

     

    Thank you for your help

    Radek

  • Profile Image
    NeilVicente
    Answered on March 29, 2011 at 05:16 AM

    Hi Radek,

    You do not always have to refer to the field name to find the correct {identifier} for that field name. In the form that you have mentioned, the one that has default value "Hotel Ostrov ****", the identifier {ubytovaciZarizeni} is correct because it shows up on the email notification. However, that isn't always the case for all of your forms that has the field name "Ubytovací zařízení: ". It doesn't always have to be {ubytovaciZarizeni} .

    To find out the correct identifier for your other forms. Click on the corresponding item on the right side of the email template. Watch this screencast for a clearer instruction.

     

    http://www.screencast.com/t/ssDVfFDnP7e

     

    Important Note: 

    Just because I used {ubytovaciZarizeni18} as the identifier for the field named " in your form http://www.jotform.com/form/10804437816 , it doesn't mean that you should use {ubytovaciZarizeni18} for all your forms that has a field named "Ubytovací zařízení"

    Hope this clears everything. 

     

    Neil