Receipt confirmation e-mail

  • Profile Image
    rallyrunner
    Asked on August 09, 2019 at 02:03 PM

    Would someone please look at my form settings and tell me why the Autoresponder won't send receipt confirmation e-mails upon submission? That's the only thing that's holding me back from upgrading to a subscription. Customers need to be able to receive receipts.

  • Profile Image
    Victoria_K
    Answered on August 09, 2019 at 02:11 PM

    Hi! 

    I see there is a condition attached to your Autoresponder, but it should still work for every case. Since your email field is required, I think condition is not needed, but you may still keep it if you want. 

    Can we perform a test submission to check the problem? 

  • Profile Image
    JohnRex
    Answered on August 09, 2019 at 02:52 PM

    Hi @rallyrunner,

    I have cloned your form, tried making a test submission and was able to receive the email autoresponder. Like what my colleague mentioned, it will still be sent for this instance, regardless if you associate it with a condition or not.

  • Profile Image
    rallyrunner
    Answered on August 09, 2019 at 04:11 PM

    John, do you have a screenshot of the Settings you used and Receipt Confirmation e-mail?

  • Profile Image
    JohnRex
    Answered on August 09, 2019 at 04:25 PM

    I have just cloned your form and made a test submission on it. No changes to the settings have been made. I just omitted the payment section to submit the form without making payments.

    Here's the screenshot of the email autoresponder that I have received.

    15653822901922033.png

  • Profile Image
    rallyrunner
    Answered on August 09, 2019 at 05:01 PM

    John,

    Okay great. I just deleted it too, and it's still doing nothing for me. But I don't even want the FirstData plugin deleted - that's literally the reason I chose Jotform - no one else offers it.

    The only way so far, that I've managed to receive an e-mail from Jotform, is by clicking the "TEST EMAIL" button in the Autoresponder section.

    Filling out the form and pressing "Submit" (regardless of whether or not the FirstData plugin is there) is not sending any Autoresponder e-mails to the e-mail provided in the e-mail textbox.

    What can I do differently here?

  • Profile Image
    JohnRex
    Answered on August 09, 2019 at 05:08 PM

    Here are my suggestions:

    1. Remove the condition for the autoresponder and see if it makes any difference.

    2. If that doesn't work, try deleting the autoresponder and then create a new one.

    3. And lastly, I can see that you haven't set the Sender Email for your Autoresponder. Please go to the autoresponder settings and choose from the dropdown. Don't forget to click Save:

    15653848791922033 2.png

    Please try that and let us know it goes.

  • Profile Image
    rallyrunner
    Answered on August 09, 2019 at 05:42 PM

    I've deleted the Condition, since it's not necessary.

    When I removed the Autoresponder and filled out the form, I received no e-mail.

    After re-creating the Autoresponder and filling out the form, no e-mail.

    After changing Autoresponder's SMTP origin to noreply@formresponse.com (the other option on that list), no e-mail.

    After changing Autoresponder's SMTP to another domain, no e-mail.

    After changing Autoresponder's SMTP to "Verified" (and providing code), no e-mail.


    I keep getting "admin" e-mails indicating that someone has filled out the form, but nothing at the e-mail addresses I use to fill out the form (trying with both gmail and personal server).

  • Profile Image
    IvayloK
    Answered on August 09, 2019 at 06:30 PM

    Can you please try to delete the e-mail field and the autoresponder and then readd them and test again?

    You can also try to test on a new form and check if the issue happens on a different form.

    Please test and let us know, if it works for you. We will wait for your response.

  • Profile Image
    rallyrunner
    Answered on August 09, 2019 at 11:22 PM

    Okay, I created a new form, tested before adding the FirstData plugin. That worked.

    Then, I added the First Data plugin, only basic settings - https://form.jotform.com/92208475501151 - and upon submission, it does not send the receipt e-mail.

    However, the Gateway ID and API password are correct, as the test order showed $1 order in the merchant backend - same as the previous form.

    It seems as though the First Data plugin is interfering with the form's ability to send e-mails. Is that possible?

  • Profile Image
    rallyrunner
    Answered on August 10, 2019 at 12:16 AM

    Okay, well this template worked. https://form.jotform.com/92210254402139 So I'm guessing it had something to do with form inputs. Deleting the other forms. Thank you for your time guys. Gonna have the boss sign up here soon, now that it'll work.