Square Integration charge custom link not working

  • Profile Image
    sbohon
    Asked on August 13, 2019 at 08:45 PM

    Upon receipt of submission for our Tiered Membership Form, the Treasurer gets no response when he clicking on the Charge Customer Now link.  The form is now in test mode.  Please take a look at submissions dated today.

  • Profile Image
    Richie_P
    Answered on August 13, 2019 at 10:58 PM

    I have tested a cloned version of your form and using the test mode I was able to charge my sample submission.

    May we know if your form is embedded to a webpage?

    Can you please try clearing your browser's cache?

    May we know if there is an error message when you try to charge the submission?

    Can you please share to us the console log when you try to charge the  customer?

    Kindly follow this guide:-How-to-get-a-console-report-from-most-common-browsers

    To post a screenshot in the thread, you may follow this guide:-How-to-add-screenshots-images-to-questions-to-the-support-forum

    Let us know how it goes.

  • Profile Image
    sbohon
    Answered on August 16, 2019 at 10:18 PM
    Yes, the form is embedded on this webpage .
    There have been no error messages.
    I asked our Treasure to clear his browser cache and create a console log. This was his reply:
    OK, I've cleared the browser (Microsoft Edge) cache, and tried to capture through Charge Customer Now in Edge and Internet Explorer and get nothing other than at the top of the screen it shows I've gone to a new location called JotForm.Submit.us ?
    We are still unable to collect payments submitted.
    Shona Bohon
    Shona Bohon, Coordinator
    Texas Municipal Courts Association
    432-634-7125
    ...
  • Profile Image
    Jed_C
    Answered on August 17, 2019 at 02:14 AM

    Sorry, but I wasn't able to see the link where the form is embedded. Can you please share it again? 

    I suspect that it's the embed code method that is causing this conflict. In case you are using the script code, please replace it with iframe https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code.

    If that doesn't work, share to us the link and we'll check.

    Looking forward for your response. 

  • Profile Image
    sbohon
    Answered on August 23, 2019 at 05:43 PM

    Here is the link to our the webpage. You will see a link named “membership application” on that page to this form. We need to get this form working as quickly as possible.
    Shona Bohon
    Shona Bohon, Coordinator
    Texas Municipal Courts Association
    432-634-7125
    ...
  • Profile Image
    Vanessa_T
    Answered on August 23, 2019 at 05:56 PM

    It seems that you tried to attach an image, unfortunately we cannot receive email attachments. To post a screenshot, please follow this guide:

    How-to-Post-Screenshots-to-Our-Support-Forum

    Aside from the webpage URL, can you also please share to us a sample submission where the issue occurred and we will try to replicate the issue on our end.