I seem to have a browser compatibility problem

  • Profile Image
    Alexander Scott
    Asked on March 18, 2013 at 01:20 PM

    Hello,

     

    We are using the sign up form on our site

    http://commongroundhelps.org/?cat=175

    We are having a problem that the site is giving an error after the user submitts.

    I have attached a screen shot.

    I think its a browser compatibility problem because it works fine in Chrome,

    but Safari, Firefox are giving the error.

    The form still seems to be giving reporting the registration even though there is an error, but it is confusing to the user.

  • Profile Image
    ardy0689
    Answered on March 18, 2013 at 01:46 PM

    Hello there,

    Thanks for posting your concerns to our JotForm Support Forum.

    I replicated this on both Firefox and Chrome. It does not seem to be browser related issue. I reviewed your form and the problem is in your site. After the form is submitted, it will use a custom URL for thank you page and it is currently set to http://commongroundhelps.org/?p=3908. Unfortunately this page in your site is non-existent or got deleted. It probably had existed before.

    Also, I would like to point something else. In here, you have already put a Custom Thank you url

     

    From your Saved Conditions, you also set 2 conditions that redirects to the same page. Even if these two conditions do not exist, the form will still redirect to the same missing page as per your Custom Thank You URL has set.

     

    These screenshots are not related to your issue. However, I would like to point these two how they conflict to each other and returns the same result. If you need further assistance, please do not hesitate to ask.

    Thanks