What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    'Next' page and *required problems with 3 forms

    Asked by Renstar6 on March 29, 2011 at 06:19 PM

    Hi,

    I have created 3 forms which are all having problems...

    They are fairly lengthy forms so I have broken them up by inserting pages... these all seem to work fine when using Firefox though if IE is being used the last 'Next' page does not work.

    I then added the required fields to 'Full Membership' and it will now not go to the next page at all and is stuck on the 1st page...

    Please help as I need to have these up and running very soon.

    Full Membership:- http://www.jotform.com/form/1364048247

    Student :- http://www.jotform.com/form/10800844397

    Companion:- http://www.jotform.com/form/10805212362

     

    Many thanks

    Renee

  • Profile Image
    JotForm Support

    Answered by NeilVicente on March 30, 2011 at 12:11 AM

    Hi,

    Can you tell me which version of IE you are using? I am using IE8 and I cannot seem to replicate your issue on my end. I had no problems navigating through your forms. Clicking Next would get me to the next page and so on. Refer to my screenshot below. You can see that I arrived to Page 5 without any problems at all.

     

    This is most likely an issue with your browser's settings. As you may know, the Back and Next buttons require Javascript to work. You can enable Javascript on your browser by following instructions in this Ehow page:  http://www.ehow.com/how_5962535_enable-javascript-ie8.html

    Hope that helps.

     

    Neil

     

  • Profile Image

    Answered by remedy66 on March 30, 2011 at 12:27 AM

    Hi...

    DOes this include moving from page 1 in the membership form with the required fields?

    Also the screen shot is of page 3... has the last page showing with the submit buttons?

    Thank you I will try with new javascript.. but please double check because it has also been a problem for others not just my computer.

    many thanks

  • Profile Image
    JotForm Support

    Answered by NeilVicente on March 30, 2011 at 01:26 AM

    Hello,

    I see now what you mean. The form is having an error when you click the Next button before the last page therefore not showing the submit button.

    The good news is that I have successfully isolated the cause of your problem. You see, browsers handle code errors differently. For example, Firefox is more tolerant of simple Javscript errors unlike Internet Explorer.

    Looking at the error codes, I found out that the cause of the problem is the mailing list subscription form that you have inserted using the Free Text HTML tool. It is causing conflicts to the script that makes your form work the way it should.

    Solution:

    Remove that particular 'alien' form. You could instead insert a link to your external mailing list subscription form.

    Hope that helps.

     

    Neil

  • Profile Image

    Answered by Renstar6 on March 30, 2011 at 06:30 PM

    Ok... I have deleted the foreign form and now on all the forms the pages go to the end of the form, FIXED!! Thank you...

    Though I am still having problems in both Firefox and IE with the Full Membership forms and the *required fields... It is still not moving beyond the 1st page even though all the required fields are filled in...

    Thank you..

  • Profile Image
    JotForm Support

    Answered by liyam on March 31, 2011 at 01:57 AM

    Hello Renee,

    I tried the Full Membership form and it worked both in IE and Firefox.  Are you still having a problem proceeding to the next pages?

    Thanks

  • Profile Image

    Answered by Renstar6 on March 31, 2011 at 02:37 AM

    Yes...?? Weird... Javascript is enabled on both browsers... not sure what is happening??

     

    Thanks

  • Profile Image
    JotForm Support

    Answered by liyam on March 31, 2011 at 05:08 AM

    This may be due to your browsers' cache.  Can you try pressing the Shift key on your keyboard and then clicking the refresh button on your browser?

    If that does not work, try to do the following:

    Firefox:

    1. Click Tools
    2. Click Options
    3. Go to Privacy Tab and click clear your recent history

    For IE8 (not sure if the rest of the versions do the same but the concept is)

    1. Click Tools
    2. Click Internet Options (bottom of the dropdown)
    3. In General Tab, under Browsing History, click the delete button.


    It would be better also if you can set your IE browser to refresh its cache everytime you visit the page repeatedly.  To do this, just beside the Delete button, click the Settings button

    A new pop up will appear and then select "Everytime I visit the webpage" under Check for newer versions of stored pages:

    Let us know if this works for you.

  • Profile Image

    Answered by Renee on April 05, 2011 at 07:06 PM

    Ok... Thank you... I did try the SHIFT and refresh button which worked once... though have since worked a little bit more on the form and none of the above solutions have worked for me and the page is still stuck on page 1.

    If this is a major problem for me to get the forms to work... then undoubtably our members will be finding problems and will not use the forms...

    Any solutions to get these forms working well ???

    Thank you

    Renee

  • Profile Image

    Answered by Renee on April 05, 2011 at 07:11 PM

    Oh and have just updated the student membership form with the required fields and this form is also doing the same thing... getting stuck at page 1.

    Thanks

  • Profile Image

    Answered by Renstar6 on April 05, 2011 at 07:31 PM

    More help needed please :)

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 05, 2011 at 10:37 PM

    Hi,

    I tried both forms in question using IE, again, without any problems. I got past page 1 and did not get stuck as you did. Take a look at this screenshots.

    This looks like an issue with either your browser's installation or your computer. So far, liyam and I had no troubles accessing your forms, and we are using different computers. Have you tried browsing your forms using another computer, perhaps a laptop?

     

    Neil

  • Profile Image
    JotForm Support

    Answered by liyam on April 06, 2011 at 02:16 AM

    When you work on your forms and try to make a preview of it, please do try again doing that Shift + Refresh or clear your browsers' cache. 

    This is because you have set your computer to load webpages faster.  By doing so, your PC is set to save files in your computer called the 'cache'.  This way, your PC is in the presumption that the visited website has the same content from the last time you visited it that's why everytime you visit the website it seems to not change and if it had the previous error, even if you already have fixed it, it will still show up there unless you clear your cache or have it fully reloaded.

  • Profile Image

    Answered by Renstar6 on April 06, 2011 at 06:32 AM

    Well... thank you for all your help!

    I have once again done the shift + refresh and it has decided to work this evening.

    Not sure why it didn't work this morning?? but thank you!

    At least I will definetly know what to inform our members if they have the same problem.

    Thanks again!

  • Profile Image

    Answered by Renee on April 06, 2011 at 06:49 AM

    Oh... this is very frustrating... sorry :(

    I tried the student form and it worked after the shift + refresh... tried the full membership form after many attempts of shift + refresh and had done this everytime I tried this morninag before writing to you again...

    I have also cleared the cache once again... which I did numerous times this morning...

    What else could the problem be? How can this be such a problem with my computer?

    I am using firefox...

    Sorry..... any more suggestions?

  • Profile Image
    JotForm Support

    Answered by liyam on April 06, 2011 at 08:33 AM

    Hello Renee,

    Can you make a screencast on this Full Membership Form page?

    Here's a free screencast that you can share here after recording: http://www.screencast-o-matic.com/.

    I also have checked your Full Membership page and recorded a screencast to show you how it works on my page: http://www.screencast-o-matic.com/watch/cXf1lroLZ

    When doing a screencast, can you also browse back to the top of the page after your next button is not pushing to the next page?

    Thanks.